Autocomplete hangs on dot in search field


  • Used Zammad version: 2.5
  • Installation method (source, package, …): deb
  • Operating system: Ubuntu 16.04
  • Database + version: postgres
  • Elasticsearch version: n/a
  • Browser + version: chrome

Expected behavior:

  • Find organisations with dot in the name, on the “new user” form

Actual behavior:

  • if an organization has a dot in the name, the autocomplete doesn’t find it, if the dot is entered

Steps to reproduce the behavior:

  • create an organization like “T.E.S.T Test, TestStandort”
  • go into the form from new user
  • search for “T”, and the organization is hwoing:
  • type the dot in the field like:
  • no search result!

See also the github issues:

it seem that is an issues with elasticsearch

Another problem is that the organization list under settings is not complete. Here is also missing the ‘“T.E.S.T Test, TestStandort”’’ entry.
In the Postgres is the entry…

We import the organization from our erp. Is there any option we missing like the search index or something?

root@ticket01:/opt/zammad# zammad run rails r “Setting.set(‘es_url’, ‘’)”
root@ticket01:/opt/zammad# systemctl stop elasticsearch

Now the search result are corrct, but now we have no elasticsearch?
It also an elasticsearch problem?

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.