Apache2 Zammad - Domain name not working, webserver only reached with IP

  • Used Zammad version: 4.1.x
  • Used Zammad installation type: (source, package, docker-compose, …) Package
  • Operating system: Ubuntu Server 20.04
  • Browser + version: Chrome most recent, Apache 2.4.41 webserver installed

Expected behavior:

Entering the domain name I have set in the zammad.conf to bring me to the webserver, furthermore pinging the domain name I have set will give me a reply from the IP of the server. DNS entries have been made for the domain name which correspond to the IP on the server.

Actual behavior:

The webserver/site can only be accessed with the IP address, and the domain name/server name does not even show in the URL bar after entering the web page in chrome. Pinging the domain name results in an error of could not find host.

Trying to use the domain name to get to the web server results in a "This site can’t be reached error + DNS_PROBE_FINISHED_NXDOMAIN error on chrome. Have tried on other browsers and its the same issue.

Posting my zammad.conf. Have tried changing the domain name, creating a servername.conf file and enabling it with a2enconf, tried restarting apache2/reloading several times, made sure the computer I was trying to access the site from is using the proper DNS server with the entries made, flushed dns, tried other browsers, restarted the VM/server, tried different port

s (80, 8081) tried entering the IP address in the brackets in the conf file like Apache suggests.

The SSL lines are commented out, however even before when they were on it did not change the scenario, I am using a self signed certificate created with OpenSSL. Redirect under the first virtual host (not sure why there is 2 virtual hosts) is commented out because I can never get the apache2 to start no matter what address I put there, it gives me an apache2 failed to start, “invalid url/can not find url in the redirect line” on zammad.conf error. I’ve even tried just commenting all of the first virtual host out and using the second, that will allow it to run but yields same issue with the domain name.

Any and all help is appreciated. Would love to be able to use the platform for our goals.

Hi, did you added the hostname in the file /etc/hosts pointing to the ip? zammad-tickets-paderm.intranet ?

And executing:

apachectl -S

show you you domain?, if not, may be you zammad file don’t end with “.conf”

Thank you for the reply, I did try adding the IP and hostname into the hosts file under /etc/ just now, it didn’t change anything. And my host does show up under apachectl -S, which is why its so confusing. It says its running with that hostname, just not accessible or pingable with it.

Just to be sure, there is an internal DNS service running in your lan that have this record (HOSTNAME A IP)?, because if you see it in your server then maybe is a DNS server problem.

1 Like

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.