After upgrade to 3.6: no users under settings


  • Used Zammad version: 3.6
  • Used Zammad installation source: (3.6 Ubuntu package)
  • Operating system: Ubuntu 18.04
  • Browser + version: Chrome 86

Expected behavior:

User should show up in the user tab (-> settings)

Actual behavior:

There are no users present anymore: no admins, no agents, no customers - though i can still login

Steps to reproduce the behavior:

What have i done

I did an upgrade from 3.5 to 3.6. First of all, i run into the same problem as mentioned here: Problem upgrade from 3.5 to 3.6 (Ubuntu Package 3.6)
Also, this solved my problem - however the user table is empty

1 Like

This seems like an issue with your Elasticsearch installation - you need the ingest-attachment plugin.
Try to run the following:

/usr/share/elasticsearch/bin/elasticsearch-plugin install ingest-attachment --batch
systemctl restart elasticsearch
zammad run rake searchindex:rebuild

After that, please restart all Zammad services.

Hope this helps.

1 Like

That was not the problem - the ingest-attachment was outdated. There was an upgrade from 7.9 to 7.10 of the elasticsearch package - i didn’t notice that.
However, i’ve uninstalled the old one - installed the new one, and now everything works fine again.

Thank you!

1 Like

Hi @benmo,
Just wanted to let you know that I tested Zammad for the first time tonight using the vagrant install and that the default setup is affected by this problem. After running the commands you provided, the users are showing up in the admin panel.
Maybe the vagrant file can be updated ?

The repo says this:

What is zammad-vagrant repo for?

This repos is meant to be the starting point for somebody who likes to test zammad. If you like to run > zammad in production you should use one of the DEB or RPM packages or try our docker-compose > repo:

and the documentation states this:

Be aware that Vagrant is meant for developers and therefore uses our unstable packages from the “develop” branch on GitHub.

To make it short:
Vagrant is no production enviroment and contains unstable develop packages. It’s for testing only.

Hi @MrGeneration, thanks for your response. I know all that, I was testing it using Vagrant as I mentioned in my message. I don’t think I wrote anything that could indicate somehting else, so I’m not sure what prompted to response in this way.

My response to @benmo was just a courtesy to let you guys know that the vagrant file did not create a zammad environment that would give the best first impression it could. It was my first try of zammad, and I kept adding users but thought zammad was broken as they didn’t show up in the lists.

Because I don’t like to keep people in the dark I’d like clarify why I was expecting you to use Vagrant by now instead of the package installation:

I thought that this is the current status quo you require help with.
This is the reason why I did tell you about the production readiness of Vagrant.

I have to admit that my response was not exactly in a manner that you should have received or expect from my end. Even if this has happened, I’d like to apologize for my response in that way.

I’ll stop working longer than I should, this should fix the issue. Again, sorry!

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.