After upgrade 5.4 to 6.0 unable to open ticket


  • Used Zammad version: 6.0
  • Used Zammad installation type: (source, package, docker-compose, …)package
  • Operating system: Centos 7
  • Browser + version: any

Expected behavior:

Actual behavior:

After upgrade to 6 unable to open ticket:

ERROR -- : PG::UndefinedColumn: 
ERROR:  column triggers.activator does not exist
LINE 1: ...ROM "triggers" WHERE "triggers"."active" = $1 AND "triggers"...

ERROR -- : PG::InFailedSqlTransaction: 
ERROR:  current transaction is aborted, commands ignored until end of transaction block

i not have any triggers

Steps to reproduce the behavior:

Upgrade 5.4 to 6.0 and try to open new ticket.

Your upgrade was not successful. Clearly database migrations didn’t run.
/opt/zammad/contrib/ should fix the issue.

Please make sure to follow the update documentation the next time:


I updated to 6.0 on my testserver and I didn’t install and start Redis before the Zammad update because it said in the docs that Zammad will install it as a dependant package for you. Yes it was installed automatically but it wasn’t running automatically and therefore the Zammad post install script didn’t work. The output repeatedly stated like “can’t connect to redis”. So make sure you have Redis up and running and then execute the post install script again.

Create an issue here, @awedor
Issues · zammad/zammad-documentation · GitHub

I had the same problem too. It installs Redis as a dependency but does not start and enable the service automatically needs to be configured manually.

It appears in the documentation that Zammad does not define it.

Your script is not documented in the upgrade guide. Anyway, this solved my problem. Thanks.

That’s what the installer runs during the upgrade installation. This why it doesn’t appear on that page. :slight_smile:


Just to add some more details for anyone stumbling around here:
That’s not default behaviour. I installed 6.0.0 coming from 5.4.1 on two deb11 machines and it worked just fine (installing redis via package manager and starting it automatically).

I only came across one problem on another machine where i fiddled around with redis myself before and didn’t cleanly uninstall it leaving zombie services/packages.


Might have worked on Debian but I tried it on CentOS 7 and it didn’t work there. And I have never fiddled around with Redis before on that machine.

I don’t really see it as an issue though. I knew of the dependancy on Redis by reading the docs and I saw the output of the installer telling me it couldn’t connect to Redis so it wasn’t a secret what the problem was. I tested it this way on purpose just to see if it would work automatically, that’s all. And I just wrote this to give OP a hint what might have been his problem if he didn’t really look at the output during install. It was just a guess based on my testing experience.

hello. Same thing here. CentOS 7, upgrade from current 5.x to 6.0.
Redis was not installed before upgrade, upgrade via yum update did install zammad 6 and redis, but not enabled it. Postinstall scripts was not processed. After update got BAD GATEWAY, discover, what redis was disabled, fixed it, discover, what ticket can not be created via web, found this ticket, and solve ticket creation issue.

Happy to find this post. We had the same issue on AlmaLinux 8. Starting Redis, then manually running the post install script sorted everything out.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.