After updating to Zammad 5, it started working much slower

  • Used Zammad version: 5.0.x
  • Used Zammad installation type: package
  • Operating system: CentOS 8 for Zammad, Windows 10 for user
  • Browser + version: Chrome 96.0.4664.110 (Official Build) (64-bit), Mozilla Firefox latest

Expected behavior:

  • zammad 5 working fast, no lags, while loading a ticket

Actual behavior:

  • when you log in, you can see list of tickets in overviews. But when you click on a ticket, then the page become unresponsible and loads a page on Firefox about 35 seconds, on Chrome it takes even more. Then I can open this ticket from list in left side of the page, but if I click on new ticket, then it again takes long time to open it. But once you loaded a ticket, then you can switch to it back very fast.

Steps to reproduce the behavior:

  • Login to Zammad 5 and try to view a ticket

I have a machine with 8GB RAM, most of it takes ElasticSearch, I changed jvmoptions to 1gb (-Xms1g -Xmx1g), it started to take less RAM, but works the same as it was before (-Xms2g -Xmx2g). I returned it back to (-Xms2g -Xmx2g).

I run the following commands

zammad run rails r ‘p Delayed::Job.count’
zammad run rails r ‘p Delayed::Job.first’
zammad run rails r ‘p Delayed::Job.last’

and got output


I dont have problems with high CPU usage (except one process RUBY (zammad) which is running 100% CPU) or disk. I dont see any ERROR messages in production.log file (I used grep command with -i error key, the it outputs nothing).

On previous version of Zammad (4th) it worked little slow but it was possible to work, but now it takes too much time to load a ticket data (especially on left side bar, where listed recently opened tickets, if the number of these tickets is small then you can work with system but very slow (about 35 seconds to view a ticket), if there is more than 10 tickets on left side bar then it loads very slow).

Do you have any suggestions how to deal with it?

Thanks in advance.

Can anybody help me with this problem or advice somthing?

hello! nobody can help me?

Hello ali, something that it work for me is the below commands.
zammad config:set WEB_CONCURRENCY=4
systemctl restart zammad

It’s possible that after run the after commands the zammad doesn’t start very well, for that situation only restart all services, like zammad-web, zammad-websocket, zammad-worker, zammad and nginx, with this zammad will be start fine.

hello JDRodriguez, thank you for reply. I tried it, but problem still exists. In my case Zammad 5 working faster on Firefox, but Chrome works slower. On Zammad 4, it was much faster in the same conditions. now the problem is, when user is logged in overviews are loaded fast, but tickets on left side are slow and page become unresponsive untill all tickets are loaded on left side bar. When you click to any ticket (does not matter if it is from left side bar or from overview), then zammad 5 starts to work very slow on client side, after it loads all open tickets then it switches between tickets on left side bar is fast, but if you click on another ticket, then it takes about 1 minute to load it on zammad 5. I suppose it somehow related with an object (tree select) with about 5 000 elements (so that in database postgresql it is about 54 000 lines due to its syntaxis). When I loaded these items into object on zammad 4, then zammad 4 started to work little slower, but after update to Zammad 5 it is very very very slow. I dont have much tickets (all tickets about 150) on Zammad and active users are also at most about 10 (including agents).

Have you already tried to delete cache from Chrome?

yes, also tried using incognito mode. and in different PCs. Also I dont see any error messages in the log.

When you update to a zammad 5, did you run the command to a elasticsearch index? I mean the below command.

zammad run rake searchindex:rebuild

On the page when you can found the guide for how to update zammad, at the end you can see some steps if the elasticsearch doesn’t work fine, maybe you can try that and then you probe again zammad, remember delete cache of Chrome after do this.
I will put the link about the steps after update for a elasticsearch.

yes, I run this command after updating to Zammad 5.

zammad run rake searchindex:rebuild

It finished succesfully.

Maybe some other suggestions? What can we do? Problem still exists, I looked for another tickets in community but didnt find any solutions yes.

any new ideas what can we do?

I found also one error, maybe it will help?

Firefox can’t establish a connection to the server at wss://

– here is replaced string

As I told before I have an Object Tree Select with about 5 000 items in 4 levels in depth (in database postgresql it is about 54 000 lines due to its syntaxis). I disabled it and Zammad started to work much faster. I think this is a cause. But I need this object in Zammad, do you have any ideas how to optimize this object?

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.