After Ubuntu uprade, authorizen issues


#1

Infos:

  • Used Zammad version: Latest from apt, I cannot say which one exactly, because stucking of version page ( “loading…”)
  • Used Zammad installation source: apt repo
  • Operating system: Ubuntu 18.04
  • Browser + version: FireFox 66.0.3

Expected behavior:

Login and do administator stuff, for instance add user
*

Actual behavior:

After Ubuntu upgrade from 16.04 to 18.04, I can login with my user, but my overview tells me I have no permissions. " Currently no overview is assigned to your roles. Please contact your administrator."
I can see some tickets on left side, but others are titled “>> Unautorhized <<”.

If I create an user, I get “Not authorized” after submitting the user add form.
And in the zammad log files I can see:
INFO – : Processing by UsersController#create as JSON
INFO – : Parameters: {“firstname”=>“test”, “lastname”=>“test”, “email”=>"", “web”=>"", “phone”=>"", “fax”=>"", “mobile”=>"", “organization_id”=>"", “department”=>"", “note”=>"", “address”=>"", “id”=>“c-230”}
INFO – : Completed 401 Unauthorized in 18ms (Views: 0.3ms | ActiveRecord: 2.2ms)

I also tried to give an current normal (static user) admin role, but the same problems.
*

Steps to reproduce the behavior:

I do not know… Maybe upgrade from ubuntu 16.04 to 18.04
*


#2

Sorry but it seems you’re mixing information which is confusing, what I understood:

You can create new tickets but do not have any rights to view them after, correct?
You can do admin-work within the admin panel, correct?

Do you know from what Zammad-Version you did upgrade?

Can you please also post information on the rights your user accounts has?
Edit: Please provide a bit more logfile (e.g. 10 lines before the 401 error and 20 after)


#3

Hi,

thanks for fast reply.
Yes I can create tickets, but I cannot view them after that.
" Opps… I’m sorry, but you have insufficient rights to open this Ticket." after creation.

I can’t do admin work, at users, I can’t see users, I can’t add user. (Not authorized)
Under groups, I can view the groups, but adding group, don’t work. (Not authorized (user)!)
And many admin pages / sections are only stucking at “Loading…” or show me blank page.

I did not recognized, that I did a zammad update with the ubuntu upgrade…, but you are right, I found in apt history, that zammad has been updated. The version before was 2.9.x

Here is the log in debug log level.
https://pastebin.com/kU1qLp1a

Its a virtualized system and switched back to my snapshot for now, and will try again if I know how to fix.


#4

Hi,

it seems there was an issue with MariaDB.
After upgrade from Ubuntu 16.04 to 18.04, mariadb 10.2 was uninstalled. I installed it, and it was running on mariadb 10.1, and there was the problem I think.

I cloned my live zammad machine, and created a a demo instance. After upgrade, I added the mariadb repo from MariaDB 10.2

sudo apt-key adv --recv-keys --keyserver hkp://keyserver.ubuntu.com:80 0xF1656F24C74CD1D8
sudo add-apt-repository ‘deb [arch=amd64] http://mariadb.biz.net.id/repo/10.2/ubuntu bionic main’

after that, worked all fine.


#5

Thanks for the feedback, glad you could make it work.
Especially for distro upgrades (for the next time) you should always do a Zammad backup before. This will also help you in case something broke.