After restoring from backup, the Owner-dropdown is always empty


  • Used Zammad version: zammad_3.1.0-1568967180
  • Used Zammad installation source: (source, package, …) package
  • Operating system: debian stretch/9.11
  • Browser + version: Chrome 77 and Firefox 69

Expected behavior:

  • When working with a ticket and clicking on the “Owner” dropdown, the list should not be empty, but contain a list of applicable owners.

Actual behavior:

  • The list is empty.
  • If opening an old ticket which had an owner, the owner field is now empty.
    • If trying to close the tab, Zammad asks if I want to discard changes, presumably because the owner has changed to empty.

Steps to reproduce the behavior:

  • Do a backup from latest Zammad using the backup-script, from a system with good amount of content.
  • Restore on another machine, with identical setup.

More details:

I have been working on migrating our Zammad-installation from one cloud provider to another. This all went smoothly it seemed, using the provided backup-script.
The new server was setup with Debian 9 and using the steps in the official documentation. All works perfectly, except that the Owner-fields are now always empty.

Before doing the backup, I ensured that the original server was upgraded to the latest version of Zammad and other dependencies.

I have tried:

  • Re-installing again on another VPS, ensuring identical Postgres and ElasticSearch (initially went from 5.x to 7.x). No difference.
  • Tried to inspect JSON-responses in front-end to try and figure out if some arrays of users/groups/roles were missing or empty, but they were included and seemingly identical, except a few differences in sorting order.
  • Tried disabling/enabling ElasticSearch, reindex and re-install the ingest-attachment plugin etc.

Nothing has any effect however. The system is perfectly usable thankfully, but all new tickets are unassigned and working with any old ticket makes it unassigned, which is quite bad for a good flow :-/

Have anybody else done a succesful migration between two identical servers recently?

I really hope somebody has a clue as what could have gone wrong! :slight_smile:

Update #1:

I also tried restoring the database (PostgreSQL) from the new VM (the broken system) and restore it into the VM of the old functional VM. Interestingly the old system’s owner field still worked, so it seems that the issue is not related to the database, but maybe ElasticSearch?

Elasticsearch has nothing to do with tan ticket owner.
Please run zammad run rails r ' Cache.clear' and relaod the webapp.

This should help.


Oh thank you SO much! I’ve spent roughly 5 hours on this issue, you saved my weekend! :wink:

1 Like

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.