Adding Own SMTP only channel leads to errror when using sendgrid.net

Infos:

Used Zammad version: 5.1.x
Used Zammad installation type: package
Operating system:

Expected behavior:

  • sends mail

Actual behavior:

Zustellung fehlgeschlagen: “Unable to send email to ‘Customer mail@somedomain.com’: Can’t use Channel::Driver::Smtp: #<OpenSSL::SSL::SSLError: SSL_connect returned=1 errno=0 peeraddr=108.128.229.184:587 state=error: wrong version number>”

Steps to reproduce the behavior:

add an SMTP only channel using smtp.sendgrid.net

mychannel = Channel.create(

area: ‘Email::Account’,

options: {

  inbound: {

     adapter: 'null',

     options: {}

  },

  outbound: {

     adapter: 'smtp' ,

     options: {

        host: "smtp.sendgrid.net",

        user: "apikey",

        password: "<key removed>",

        port: 587,

        ssl: true,

        domain: Setting.get('fqdn'),

        enable_starttls_auto: true

     }

  }

},

active: true,

preferences: {

  editable: false

},

updated_by_id: 1,

created_by_id: 1

)

i am not sure if the error is a bug or somehow related to the used configuration especially in regarding to ssl / port etc, anything i can do to help solving this issue for me?

i have also configured sendgrid to send notifications from zamamd which works without problem, so it is probably more about how to add the channel corretly then an actual bug

if i use port 465 it works, however sendgrid does recommend using port 587 (and i am using that port when sending notifications from within zammad)

Zammad “guesses” the encryption method suitable for SMTP channels. This is due how Ruby works as far as I’m aware. You cannot provide a specific encryption type as of now. You may want to stick to 465 if it is working and supported by sendgrid.