Add "sent on behalf of" information to ticket response

Hi, I need to include the sender’s information for the agent and thus facilitate identification in the responses for users. Does anyone know if it is possible to include the text “sent on behalf of”.
The way I use Zammad is only open by email, so this identification in the answers is sorely missed.

I searched but found no answers.

Anyone who can help, I am very grateful.

Hi @AlanPatrick

I believe this is the default behavior but instead of “sent on behalf of” it says “via”

Go to: Settings > Channels > Email > Settings

and there you can edit the literal.

HTH,
Martin

Hi @rsysadmin
thanks for your help.
I tried to change the setting but it didn’t work. When sending a test message appears only with the display name of the sender. As if it were just the System Address Display Name.

The email account set up in Zammad is SMTP for Office365.

I could even send just the name of the agent, without the need to include VIA.
Do you know if it is possible to include only the name of the Agent?

tks

Hi @AlanPatrick

do you have a group associated with the account for inbound emails?

All the tickets I have replied via email do have the “Martin via Helpdek” on the “From:” field…

Regards,
Martin

Keep in mind that -if- you check that mail with outlook, it will fiddle the display name around in some cases. You may have to look into the source code of the mail and look for “FROM:” to double check.

@rsysadmin, I have the group associated with the account. Tks!

@MrGeneration ,
the outlook really changed the display name, I did a test for external email and saw that Alan Patrick appeared via Zammad correctly!

Do you know if there is any way around this for my users to see that I sent it through Zammad?

The display name is a outlook based issue and usually the local “learning” address book.
Only solution is to manually remove that one entry from that address book or destroy the outlook profile and create a new one.

Probably both paths are not really practical.

Hi Mr.!
A few weeks ago I did the procedure to recreate the address book but it didn’t work out. He insists on keeping only the name of the main O365 account.

Do you know if the problem may be due to the configuration using “E-mail” instead of the new “Microsoft 365” method inside Zammad? I didn’t quite understand the difference in using this Microsoft 365 configuration.

Display names technically do work identically in between “normal” email channels and microsoft 365 channels. You can provide a display name per email address ( see Secondary Addresses — Zammad documentation ) which by default will end up in something like agent name via display name. You can change the format within “settings” tab via “sender format” if needed.

You’ll want to upgrade to microsoft 365 channels any way, because Microsoft is going to discontinue basic authentication. Microsoft 365 channel uses token based authentication.

All required steps can be found here:
https://admin-docs.zammad.org/en/latest/channels/microsoft365/accounts.html