Add Salutation/Title to User Attributes


I am currently testing Zammad as an internal ticket system and I am very happy with it so far, however there is one feature I think is missing and that is a Salutation/Title field in the User attributes. I am no native English speaker, but in Germany it is pretty common to formally greet someone with the following phrase:

Dear Mr John Doe,

However without the title attribute, I always have to write

Dear Mr/Ms John Doe,

If I were able to set a user attribute for that, it would be really helpful and I could also sync it with the Active Directory title attribute for example.

Hi @mlhb
in the Admin Interface (German: Verwaltung) you can add a property for tickets, users, organsisation and groups.
There you can add an property for the Salutation/title (Anrede) an with the LDAP Integration you could mapp the AD attribute to this field.


Thank you very much, I didn’t know you could do that.

Hi @mlhb (Marek),

were you able to solve your requirement?

@Community: Excuse me please: Im not an native english speaker too. :wink:

Yes, that solved it. Thanks again.

Hello @mlhb

can you please post an screenshot of what you did? :slight_smile:

Thanks in advance!


As @StephanBuerger suggested, I went to Settings → Objects → Users and added a new attribute (see Screenshot below)

Everything beneath “Definiere hier …” I left at default, because it was fine for me.
Then I went to Settings → Integration → LDAP and clicked on Change, then just clicked through until I got to the point, where you can map LDAP attributes to Zammad User attributes. Then I simply clicked on “Add” and mapped my newly created title attribute to the according LDAP attribute. After that, click on “Sync Now”, which depending on the user count can take some time. After that I just made sure, that the attribute shows up when inspecting a user in the users tab.

1 Like

You may run into this issue in case you have customers without the salutation attribute set:

In short, if you use your #{ticket.user.anrede} without anything set for anrede, zammad will print out “-” instead of an empty string…

Hi @ckuganda Carsten,

is it possible that the issue is the NULL in the Database?
I have not tested it but maybe there is a different between a NULL and an empty string?

Hi Stephan,

no that’s not the issue. Just enter some spaces into a text object via the Zammad UI: The field remains “empty” and shows a “-” when used in placeholders

This topic was automatically closed after 416 days. New replies are no longer allowed.