503 Error - No protocol handler was valid for the URL /ws

  • Used Zammad version:
    Zammad Version 2.6.x

  • Used Zammad installation source: (source, package, …):
    Zammad from https://dl.packager.io/srv/deb/zammad/zammad/stable/ubuntu 18.04 main

  • Operating system:
    Ubuntu 18.04 4.15.0-36-generic x86_64 GNU/Linux

  • Webserver:
    Server version: Apache/2.4.29 (Ubuntu)
    Server built: 2018-10-03T14:41:08

  • Browser + version:
    Firefox 62.0.3 (64-Bit)

Expected behavior:

No Errors

Actual behavior:

  • When I’m entering our Zammad URL, everything is working fine, but I noticed the 503 Error.

With a Apache log telling me:

**[Thu Oct 11 16:32:54.104903 2018] [proxy:warn] [pid 4287:tid 139648034662144] [client] AH01144: No protocol handler was valid for the URL /ws (scheme 'ws'). If you are using a DSO version of mod_proxy, make sure the proxy submodules are included in the configuration using LoadModule.**

But I’v got already the required Modules enabled:

apache2ctl -M

Loaded Modules:
 core_module (static)
 so_module (static)
 watchdog_module (static)
 http_module (static)
 log_config_module (static)
 logio_module (static)
 version_module (static)
 unixd_module (static)
 access_compat_module (shared)
 alias_module (shared)
 auth_basic_module (shared)
 authn_core_module (shared)
 authn_file_module (shared)
 authz_core_module (shared)
 authz_host_module (shared)
 authz_user_module (shared)
 autoindex_module (shared)
 deflate_module (shared)
 dir_module (shared)
 env_module (shared)
 filter_module (shared)
 headers_module (shared)
 mime_module (shared)
 mpm_event_module (shared)
 negotiation_module (shared)
 proxy_module (shared)
 proxy_http_module (shared)
 proxy_wstunnel_module (shared)
 reqtimeout_module (shared)
 rewrite_module (shared)
 setenvif_module (shared)
 socache_shmcb_module (shared)
 ssl_module (shared)
 status_module (shared)

My Apache Config is:

<VirtualHost *:80>
    # replace 'localhost' with your fqdn if you want to use zammad from remote
    ServerName our.domain.com

    ## don't loose time with IP address lookups
    HostnameLookups Off

    ## needed for named virtual hosts
    UseCanonicalName Off

    ## configures the footer on server-generated documents
    ServerSignature Off

    ProxyRequests Off
    ProxyPreserveHost On

    <Proxy localhost:3000>
        Require local

    ProxyPass /assets !
    ProxyPass /favicon.ico !
    ProxyPass /robots.txt !
    ProxyPass /ws ws://localhost:6042/
    ProxyPass / http://localhost:3000/

    DocumentRoot "/opt/zammad/public"

    <Directory />
        Options FollowSymLinks
        AllowOverride None

    <Directory "/opt/zammad/public">
        Options FollowSymLinks
        Require all granted


netstat -tulpn

tcp        0      0 *               LISTEN      639/systemd-resolve
tcp        0      0    *               LISTEN      706/sshd
tcp        0      0*               LISTEN      678/puma 3.11.0 (tc
tcp        0      0*               LISTEN      859/postgres
tcp        0      0*               LISTEN      648/script/websocke
tcp6       0      0          :::*                    LISTEN      739/java
tcp6       0      0 ::1:9300                :::*                    LISTEN      739/java
tcp6       0      0 :::22                   :::*                    LISTEN      706/sshd
tcp6       0      0 :::443                  :::*                    LISTEN      4278/apache2
tcp6       0      0 :::80                   :::*                    LISTEN      4278/apache2
tcp6       0      0          :::*                    LISTEN      739/java
tcp6       0      0 ::1:9200                :::*                    LISTEN      739/java
udp    21504      0 *                           639/systemd-resolve
  • Firewalls are completly disabled
  • No Proxy , transparent proxy or any kind of proxy

Does someone has an idea what is missing here ?

I just implemented SSL and used this config and it seems to work. Zammad Apache2 SSL Config

No idea why because the config is the same but with ssl.

What was the problem ?

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.