Updated 2.9.0 -> 3.0.0 (source, ubuntu-18.04): No issues

I just finished updating my zammad instance, no issue at all. I’m using the source installation on ubuntu-18.04.

Near the end, I’ve seen these warnings:

...
Bundle complete! 99 Gemfile dependencies, 141 gems now installed.
Gems in the groups test, development and postgres were not installed.
Use `bundle info [gemname]` to see where a bundled gem is installed.
Post-install message from i18n:

HEADS UP! i18n 1.1 changed fallbacks to exclude default locale.
But that may break your application.

Please check your Rails app for 'config.i18n.fallbacks = true'.
If you're using I18n (>= 1.1.0) and Rails (< 5.2.2), this should be
'config.i18n.fallbacks = [I18n.default_locale]'.
If not, fallbacks will be broken in your app by I18n 1.1.x.

For more info see:
https://github.com/svenfuchs/i18n/releases/tag/v1.1.0

Post-install message from icalendar:
ActiveSupport is required for TimeWithZone support, but not required for general use.

I ignored them and everything seems to work well. Do you propose any action?

Thanks for your work and support, Uli

Maybe @thorsteneckel can tell :slight_smile:

1 Like

Hey Uli! These are only warnings /notices to us (the developers) that some things in our dependencies have changed. We already covered that so you can just ignore it. Have a good time using Zammad 3.0!

2 Likes

Thanks a lot for your feedback. So far, my team is very pleased with the new version. They didn’t even notice the update :wink: I’ll ask them to play with the knowledgebase next week and post my findings here. Schöne Pfingsten und vielen Dank nochmal für die tolle neue Version! LG,Uli

1 Like