"Zeig mir dies in Zammad" link points to http instead of https

Infos:

  • Used Zammad version: 5.0.x
  • Used Zammad installation type: docker-compose
  • Operating system: Debian GNU/Linux 11 (bullseye)
  • Browser + version: any

Expected behavior:

  • the link “Zeig mir dies in Zammad” link points to https

Actual behavior:

  • “Zeig mir dies in Zammad” link in the mails from noreply@ points to http

Steps to reproduce the behavior:

The server is running behind a nginx proxy which handels the ssl encryption.
Setting.set(‘http_type’,‘http’)

If I set
Setting.set('http_type','https')
I get the CSRF token error

with Setting.set('http_type','http') I have the wrong link in mails.

How to configure the mails correctly to point to https?

1 Like

ok, I found the right location to fix the https issue

less docker-compose.override.yml

version: '3'
services:

  zammad-nginx:
    ports:
      - "8080:8080"
    environment:
      - VIRTUAL_HOST=zammad.example.com
      - NGINX_SERVER_SCHEME=https

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.