Zammad webpage in Firefox only displayed after hitting F5


  • Used Zammad version: 3.1.x
  • Used Zammad installation source: (source, package, …) Zammad Community Edition
  • Operating system: Ubunbtu Server 18.04 LTS
  • Browser + version: Firefox 67.0.4 (64-Bit) under Windows 10

Expected behavior:

Actual behavior:

  • A grey blank page is displayed
  • If I hit F5 (refresh), the dashboard is displayed.

Steps to reproduce the behavior:

  • Open Firefox Browser (same behavior with Google Chrome and M$ Edge)
  • Enter URL to local zammad server in address bar and press Enter.

Open your browser dev tools, navigate to your Zammad instance, and then check especially the console and the network tab. Are there any obvious error messages? I suspect that there might be an issue when it attempts to load application.js.

Thank you for the quick response.

XHR POST is very slow.
It takes 14256 ms. See attached screenshot from browser developer tools.

It seems that this long duration occures only after some idle time.

After the dashboard is shown, the page reacts quickly. So I don’t think its a hardware bottleneck.
The ubuntu server runs as VM in a local Nutanix cluster.

Could you please share the hardware specifications of your machine?
Also how many agents are using this installation concurrent?

If signshow takes 15 seconds to do stuff, you have a bottleneck somewhere between you and your server or on the server. Zammad can react very slow depending on what the current situation on the machine is (for several reasons)

The VM has 1 vCPU and 2 GB RAM assigned.
We’re using the Nutanix Acropolis Hypervisor (based on KVM)
We have 2-3 concurrent agents (only LAN).
My client computer is on the same site. LAN connection is 1 GBit/s.

Performance VM:

Nutanix Host Hardware is Dell XC430 with Xeon E5-2630v4 CPUs. 188 GB RAM.
Storage system is hyperconverged with SDDs and HDDs.

Performance Host System:

2 GB RAM is most probably not enough. The hardware requirements say:

  • 4 GB of RAM (+4 GB if you want to run Elasticsearch on the same server)

OK, then I will assign more RAM.

Thank you so much.

Adding more RAM worked like a chram.
Problem solved.

1 Like

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.