Zammad on shared server with apache setup problem

  • Used Zammad version: latest
  • Used Zammad installation source: (source, package, …) package from installer
  • Operating system: Debian 9.3
  • Browser + version: Firefox 59

Expected behavior:

  • Have a own server, where i want to run zammad on. I also have virtualmin on that server, because it has quite perfomance overhead. One of the virtual servers should be the “host” for zammad like So, when i enter that in a browserwindow, it should open zammad.

Actual behavior:

  • Differs on config: Sometimes it says You don’t have permission to access / on server.
    If i have all those ssl / proxy directives from the apache conf in my .conf file, it says this:

SSL Proxy requested for but not enabled[Hint: SSLProxyEngine
HTTPS: failed to enable ssl support for (localhost)

I googled around several hrs, just to find out, that there should be a nginx installation as well, which isn’t.

I followd this installation guide:

So i am a little bit confused. my apache conf file from virtualmin looks like this:

DocumentRoot /opt/zammad/public

don’t loose time with IP address lookups

HostnameLookups Off

## needed for named virtual hosts
UseCanonicalName Off

## configures the footer on server-generated documents
ServerSignature Off

SSLProxyEngine on

ProxyRequests Off
ProxyPreserveHost On

<Proxy localhost:3000>
Require local

 ProxyPass /assets !
ProxyPass /favicon.ico !
ProxyPass /robots.txt !
ProxyPass /ws ws://localhost:6042/
ProxyPass / https://localhost:3000/
Options FollowSymLinks AllowOverride None
<Directory /opt/zammad/public>
    Options FollowSymLinks
Require all granted

ErrorLog /var/log/virtualmin/support.example.com_error_log
CustomLog /var/log/virtualmin/support.example.com_access_log combined
ScriptAlias /cgi-bin/ /home/example/domains/
ScriptAlias /awstats/ /home/example/domains/
DirectoryIndex index.html index.htm index.php index.php4 index.php5
<Directory /home/example/domains/>
Options -Indexes +IncludesNOEXEC +SymLinksIfOwnerMatch
allow from all
AllowOverride All Options=ExecCGI,Includes,IncludesNOEXEC,Indexes,MultiViews,SymLinksIfOwnerMatch
Require all granted
AddType application/x-httpd-php7.0 .php7.0
AddType application/x-httpd-php .php

<Directory /home/example/domains/>
allow from all
AllowOverride All Options=ExecCGI,Includes,IncludesNOEXEC,Indexes,MultiViews,SymLinksIfOwnerMatch
Require all granted

RewriteEngine on
RewriteCond %{HTTP_HOST}
RewriteRule ^(.) [R]
RewriteCond %{HTTP_HOST}
RewriteRule ^(.
) [R]
SSLEngine on
SSLCertificateFile /home/example/domains/
SSLCertificateKeyFile /home/example/domains/
SSLProtocol all -SSLv2 -SSLv3 -TLSv1 -TLSv1.1

AuthName “ statistics”
AuthType Basic
AuthUserFile /home/example/domains/
require valid-user

RedirectMatch /cgi-bin/mailman/([^/.])(.cgi)?(.)$1.cgi$3
RedirectMatch /mailman/([^/.])(.cgi)?(.)$1.cgi$3
Alias /pipermail /var/lib/mailman/archives/public

i didn’t care about port 80 setup, since i wanted to run it on https.

The SSLProxyEngine on i found by googling around, but this didn’t help either. When i outcomment all the proxy stuff, i get this error:

Cannot serve directory /opt/zammad/public/: No matching DirectoryIndex (index.html,index.htm,index.php,index.php

i also had this error: No permission to serve / which i got around by adding my virtual host user to the zammad group and zammad user added to my virtual hosts users group.

I would have tried uninstall and re-install, but haven’t found information about that either. I know, apache ist quite uncommon for zammad. Coming from OTRS, where i was able to run it in that way i outlined above, i thought, this would be possible with zammad as well.

Any idea truly appreciated.

I might be barking up the wrong tree, but perhaps it is just a little something somewhere, which i can’t see :slight_smile:


PS: I am also confused, since my opt/zammad/public dir only contains this:

Am i missing here something?

I was a little bit… well, confused.
I ended up with this:

-rename the virtualmin’s host conf file in /etc/apache2/sites-available
-copy over the zammad apache conf file
-restart apache2


I am currently looking into the ssl thing, i am wondering how i can get this done, with existing shared cert, how to integrate that one.

But i am glad, it is working now, somehow.


Another questions:

  1. Can i see the images, being sent with the mail also inline in the ticket, without having to open Paint or the like?

  2. I don’t get it with the Users / Groups and Organisations. I have a new user, which belongs to an organisation. But how am i able to put it in a group?`I created a Group for that Organisation, but the User sticks in the Users group, which does not utilize an Emailaddress, therefore i can’t send emails, But i want that user being in a specific group which HAS an email address, so how can i put that user in a specific group? Whereas i find a lot documentation about each module, i am missing the eagle’s view, putting all pieces together. Some things i worked out on my own, but, anybody able to push me in the right direction?

  3. Will we have some sort of Knowledgebase somewhen? would be brilliant.

Thanks and best

Well, it seems, that it doesn’t really work that way i supposed it to by running it on a server which also runs virtual webservers, due to the apache config and https problem. therefore i will give it a try with a root server, which just does this and some other serveronly based software, which has not to be available for all websites.

Any advice how to remove zammad from the first one, please?

I am still wondering about the User Group issue above, no idea, anyone?

Thanks and best

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.