Zammad integrated with OAuth

Hi i finished of configure the OAuth between Zammad and Gmail, i think and readed that this is for that my customers can create accounts in zammad with your own accounts of Gmail

image

But when i access to my system appear me the google option

And when i try access appear me this message

image

Somebody can help me.

You need to change your redirect URI. Go to your OAuth app and set the redirect URI to https://helpdesk.gsperu.pe/auth/google_oauth2/callback.

image

(Second field in the screenshot)

1 Like

Thanks @benmo this work but where was it extracted from was URI? because I wrote the one that Zammad gave me.

Also once the user has been created in my system, is it normal for his username to be numbers?

image

Shouldn’t it be the email username myaccount@domain.com?

The Redirect URI was in the error message and is passed to Google IDP over the URL attribute redirect_uri. Where did Zammad tell you this Redirect URI? Here would be the correct documentation for this, with the correct URI.

If you click on the user, do you see his email address listed in his profile? I believe that this is normal behaviour and it’s no problem because the user won’t be able to login with his username anyway.

Hi, thanks for you response and you’re right maybe this user is ok cause the login is with the ggogle acccount.

The valor that i can obtain is from the same system and is in this section:

image

But your link is right and thanks for this information

1 Like

You were in the wrong place in the settings. You were under Channels/Google, which is used for connecting Gmail Account. To set up OAuth, go to Settings/Security/Third-party Applications/Authentication via Google.

Hope everything is working now.

1 Like

Thanks for you help. Good luck

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.