Zammad installation/update not possible anymore on Ubuntu 18.04


  • Used Zammad version: 3.2.0-1567170593.c8ef7698.bionic
  • Used Elasticsearch version: 5.6.16
  • Used Zammad installation source: package
  • Operating system: Ubuntu 18.04
  • Browser + version: Firefox 68.0.2

Expected behavior:

  • Clean install of zammad works

Actual behavior:

  • At the moment, i could not install zammad due to an error in postinstall

Steps to reproduce the behavior:

  • Just install zammad

Zammad still was installed successfully on my system and worked well … until something went wrong within an update. Since then, i get an error everytime i try to update my zammad version:

The mentioned “permission denied” error regarding the newly created temp file is very strange: the postinstall script created the file, has written all the postinstall stuff in it and set the execution flag. But the error appears anyway.

I tried everything to solve this issue including the manual installation of older versions, but nothing worked. The last thing i’ve tried was to completely remove zammad from my machine and delete all files and folders. But i still get this strange error.

Any other packages could be installed without any problems and i didn’t found additional hints in any logfile (syslog etc.)

Anyone an idea what i can do?

Thanks and regards,

Are you aware that you’re installing the develop version of Zammad?
(Just out of my interest)

Also, I’m sorry, but I can’t help here, as I believe that this is system related (which is out of scope for us from Zammad).

Line 53 says: "${tmpfile}" "$@"
This is calling the tmp-file, so I guess the user (which should be root I suppose, can’t seem to read the content of that file.

You might want to ensure that /tmp is readable (or even available).

Hi, thanks for your reply.

First of all, yes i’m aware that i’m using a develop version - this was a desperate attempt to fix the install issue :slight_smile:

Your’re right, there seems to be a permission problem, but i’m logged in as root and the access rights are correct as well. Here are several temp files created within install procedure:


As you can see, the execution flag was set correctly to all temp files.
For the moment i could call the file “/opt/zammad/contrib/” manually, which does all the postinstall stuff that is needed. The file content is the same as in the temp file!



calling the postinstall-script manually does help with migrations and stuff, but proberbly won’t solve your problem, as the installation process seems to have trouble reading / accessing that data. Proberbly the install will keep failing.

Still, sorry, that’s how far I can help. :confused:

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.