Zammad Chat Default Messages

  • Used Zammad version: 4.1.x
  • Used Zammad installation type: (package)
  • Operating system: Ubuntu 20.4.0
  • Browser + version: Chrom Edge

Expected behavior:

I tried updating the default text in Chat.js and others to update the default text messages in Zammad chat including (Connecting, All colleagues are busy, etc…)
*

Actual behavior:

Whatever I change nothing is happening to Zammad Chat Messages … seems like I can’t locate the source where it is configured
*

Steps to reproduce the behavior:

Edit Chat.js or Chat.coffee
*

You mean this file…?

Note that changing source files is a) not update safe and b) requires precompiling in most situations.
You should only use that option if you understand the scopes you’re changing because other wise you may break stuff.

zammad run rake assets:precompile does the precompile.
Don’t forget to clear caches…

You could set the map before chat init.

ZammadChat.prototype.translations = {} 
const chat = new ZammadChat({})

Hello, This is yes the defaults but these are translations. I want to change the English version of the text and not add any translations.

Well yes then you gotta change the originating strings.
They look like so:

It’s simply not supported by Zammad core to adjust the originating strings.
This is as far as I can help. Good luck!