Zammad 2.9 not retrieving mail and very slow

  • Used Zammad version:
    Zammad 2.9
  • Used Zammad installation source: (source, package, …)
    last of the depot
  • Operating system:
    Ubuntu 16.04

First thank you very much for your help.

Actual behavior:

Since the update from 2.8 to 2.9, zammad is no longer retrieving mails automatically and it’s very slow. The background jobs are always increasing.
I send you the content of the monitoring page
*

healthy false
message " channel is active but not fetched for about 6 hours; channel is active but not fetched for about 6 hours; channel is active but not fetched for about 6 hours; channel is active but not fetched for about 6 hours;unprocessable mails: 1;scheduler may not run (last execution of Chat.cleanup 2 days over) - please contact your system administrator;14145 background jobs in queue"
issues
0 " channel is active but not fetched for about 6 hours"
1 " channel is active but not fetched for about 6 hours"
2 " channel is active but not fetched for about 6 hours"
3 " channel is active but not fetched for about 6 hours"
4 “unprocessable mails: 1”
5 “scheduler may not run (last execution of Chat.cleanup 2 days over) - please contact your system administrator”
6 “14145 background jobs in queue”

Thank you very much for the help, I’m totally stuck I don’t now how to solve that.

my production.log

I, [2019-03-02T20:54:28.847565 #17841-47114925338440]  INFO -- : Setting.set('product_logo', "4f05f74a9601ef2bbbc6540483083f7d.png")
I, [2019-03-02T20:54:32.109158 #17841-47114925338440]  INFO -- : Scheduler started.
I, [2019-03-02T20:54:32.115172 #17841-47114925338440]  INFO -- : Cleanup of left over locked delayed jobs 2019-03-02 19:54:32 UTC started.
I, [2019-03-02T20:54:32.146690 #17841-47114925338440]  INFO -- : Checking left over delayed job #<Delayed::Backend::ActiveRecord::Job id: 3092249, priority: 0, attempts: 0, handler: "--- !ruby/object:BackgroundJobSearchIndex\nobject: ...", last_error: nil, run_at: "2019-02-26 15:46:11", locked_at: "2019-02-26 15:46:12", failed_at: nil, locked_by: "host:helpdesk pid:21384", queue: nil, created_at: "2019-02-26 15:46:11", updated_at: "2019-02-26 15:46:11"> started.
I, [2019-03-02T20:54:32.282457 #17841-47114925338440]  INFO -- : Scheduler stopped.
I, [2019-03-02T20:54:32.896597 #3706-47267957873360]  INFO -- : Started GET "/api/v1/monitoring/health_check?_=1551529843206" for 179.26.8.63 at 2019-03-02 20:54:32 +0100
I, [2019-03-02T20:54:32.902985 #3706-47267957873360]  INFO -- : Processing by MonitoringController#health_check as JSON
I, [2019-03-02T20:54:32.903042 #3706-47267957873360]  INFO -- :   Parameters: {"_"=>"1551529843206"}
I, [2019-03-02T20:54:32.929567 #3706-47267957873360]  INFO -- : Completed 200 OK in 26ms (Views: 0.2ms | ActiveRecord: 14.7ms)
I, [2019-03-02T20:54:36.588875 #17872-47456895979360]  INFO -- : Setting.set('product_logo', "4f05f74a9601ef2bbbc6540483083f7d.png")

Hi,

we have the same issue.

  • channel is active but not fetched for about 2 hours
  • scheduler may not run (last execution of RecentView.cleanup 3 days over) - please contact your system administrator

Hi @lobiman - we fixed an issue just yesterday which caused high system load and an unstable overall system. Please update to the latest version of 2.9 and let us know how it went :crossed_fingers:

Hi,

the issue was after updating to 2.9.

The problem probably was an error while updating to 2.9. The reason why the scheduler was crashing on each startup was a older Job from an older Zammad Version, which was not completed.

Solution was:

  1. Run the followed commands

Delayed::Job.where(“handler LIKE ‘%Observer::ticket::UserTicketCounter::BackgroundJob%’”).count

Delayed::Job.where(“handler LIKE ‘%Observer::ticket::UserTicketCounter::BackgroundJob%’”).delete_all

After we have restarted Zammad and monitor the Job count

Delayed::Job.count

Delayed::Job.first

@Benjamin maybe you have the same problem and this solution will help you.

1 Like

I solved it doing that

zammad run rails c
Delayed::Job.find( 3092249).destroy

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.