Undefined method `color_header_link after upgrade to 5.0.1

Infos:

  • Used Zammad version: 5.0.1
  • Used Zammad installation type: (source, package, docker-compose, …) debian apt
  • Operating system: debian 10
  • Browser + version: FF 93

Expected behavior:

I would like to update color of Knowledge Base

Actual behavior:

After Upgrade to 5.0.1, it seems something went wrong.
For example when I try to update color of Knowledge base, I got this error
{"error":"undefined method color_header_link’ for #\u003cKnowledgeBase:0x00007fb350975da0\u003e\nDid you mean? color_header\n color_header?\n color_header=\n color_header_was\n color_header_change"}`

Someone I have idea about this problem?

You did follow the update documentation ( Updating Zammad — Zammad documentation ) and no error messages were thrown during update installation?

From which version did you upgrade?

Right.
Checked log, Seems there was a problem with database.
I try once again. But this time I upgrade postgrsql before upgrade zammad.
stop elastic too.

This time zammad upgraded correctly without error :slight_smile:

1 Like

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.