Unable to process GET request to elasticsearch (Unknown time-zone ID: Europe/Kyiv)

Infos:

  • Used Zammad version: 5.2.x
  • Used Zammad installation type: (package)
  • Operating system: Cent OS 8
  • Browser + version: any

Expected behavior:

  • Search results

Actual behavior:

  • There is no match for your search.

Steps to reproduce the behavior:

If default time zone is set to Europe/Kyiv (GMT+3), ther is an error in production log.

**Payload:**
{"from":0,"size":"10","sort":[{"updated_at":{"order":"desc"}},"_score"],"query":{"bool":{"must":[{"query_string":{"query":"255855*","time_zone":"Europe/Kyiv","default_operator":"AND","analyze_wildcard":true}}],"filter":{"terms":{"kb_locale_id":[1]}}}}}

Payload size: 0M
E, [2022-09-17T13:45:26.631257 #93429-110580] ERROR -- : Unable to process GET request to elasticsearch URL 'http://localhost:9200/zammad_production_ticket/_search'. Check the response and payload for detailed information:

**Response:**
#<UserAgent::Result:0x00005648619ed6a8 @success=false, @body="{\"error\":{\"root_cause\":[{\"type\":\"x_content_parse_exception\",\"reason\":\"[1:300] [bool] failed to parse field [must]\"}],\"type\":\"x_content_parse_exception\",\"reason\":\"[1:300] [bool] failed to parse field [must]\",\"caused_by\":{\"type\":\"zone_rules_exception\",\"reason\":\"**Unknown time-zone ID: Europe/Kyiv**\"}},\"status\":400}", @data=nil, @code="400", @content_type=nil, @error="Client Error: #<Net::HTTPBadRequest 400 Bad Request readbody=true>!", @header={"x-elastic-product"=>"Elasticsearch", "warning"=>"299 Elasticsearch-7.17.6-f65e9d338dc1d07b642e14a27f338990148ee5b6 \"Elasticsearch built-in security features are not enabled. Without authentication, your cluster could be accessible to anyone. See https://www.elastic.co/guide/en/elasticsearch/reference/7.17/security-minimal-setup.html to enable security.\"", "content-type"=>"application/json; charset=UTF-8", "content-length"=>"191"}>

Only I make changes in default timezone (for example Europe/Helsinki (GMT+3) ) - everything works fine. But after some time my default time zone back to Europe/Kyiv.
I tryed to change my centos 8 default timezone to Helsinki, but no effect in Zammad – after some period of time it reverts to Europe/Kyiv (GMT+3)
Video is in attachment.