Time accounting max value error

Good day, I am unsure whether this is a bug or planned behaviour.

Infos:

  • Zammad 3.3.x
  • Used Zammad installation type: Office Zammad yum/OS repo
  • Operating system: CentOS 7
  • Browser + version: Firefox 97.0

Expected behavior:

  • When closing a ticket and entering a time accouting of 10000 or more the time accounting should accept it.

Actual behavior:

  • When closing a ticket and entering a time accouting of 10000 or more
  • An error is raised and the ticket is not saved
  • The error raised is: PG:NumericValueOutofRange Error: Numeric Field Overflow

Steps to reproduce the behavior:

  • Enable Time accounting
  • Open a ticket - wait a while
  • Close the ticket with a comment
  • A time accounting window should pop up
  • Enter a value greater or equal to 10000

Sorry but I will not provide any help to such outdated installations.
You are prune to several tons of security issues.

Please consider upgrading to Zammad 5.1 as soon as possible.
See: Updating Zammad — Zammad documentation

Please make sure to read the release notes before updating so you’re aware of possible breaking changes: News, Updates, Releases | Zammad

Hi @MrGeneration,

The system has been upgraded to: Zammad version 5.0.x
The issue persists.