Time accounting max value error

Good day, I am unsure whether this is a bug or planned behaviour.


  • Zammad 3.3.x
  • Used Zammad installation type: Office Zammad yum/OS repo
  • Operating system: CentOS 7
  • Browser + version: Firefox 97.0

Expected behavior:

  • When closing a ticket and entering a time accouting of 10000 or more the time accounting should accept it.

Actual behavior:

  • When closing a ticket and entering a time accouting of 10000 or more
  • An error is raised and the ticket is not saved
  • The error raised is: PG:NumericValueOutofRange Error: Numeric Field Overflow

Steps to reproduce the behavior:

  • Enable Time accounting
  • Open a ticket - wait a while
  • Close the ticket with a comment
  • A time accounting window should pop up
  • Enter a value greater or equal to 10000

Sorry but I will not provide any help to such outdated installations.
You are prune to several tons of security issues.

Please consider upgrading to Zammad 5.1 as soon as possible.
See: Updating Zammad — Zammad documentation

Please make sure to read the release notes before updating so you’re aware of possible breaking changes: News, Updates, Releases | Zammad

Hi @MrGeneration,

The system has been upgraded to: Zammad version 5.0.x
The issue persists.

well … I was talking about 5.1…

Same thing here,
Im using Zammad 5.1.1-1651065605.a969cd44.focal on Ubuntu server 20.04LTS
Already tried to change lenght and scale time_units over ticket_time_accountings table on Postgres.
Maybe there is a config we can change to allow more than 10000 time units in a ticket.
I’ll keep looking for a solution, if I solve it I’ll let you know.

Just updated to 5.2.1.
Still not working.

Okay. So you’re saying a accounted time of 9,999 time units is not enough for your use case?
If so create a bug report on the repo GitHub - zammad/zammad: Zammad is a web based open source helpdesk/customer support system

Might be an edge case if you’re unlucky, I can’t decide that.


At the time the field was meant to mean minutes. So 1800 minutes would mean a task took 30 hours. The longest task you can record is ~166 hours.

Due to context, the use case no longer applies and if it is deemed best to close this ticket it - let it be.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.