This message cannot be displayed due to HTML processing issues

Infos:

  • Used Zammad version: 5.2.3
  • Used Zammad installation type: Package
  • Operating system: Ubuntu 20.04.5 LTS
  • Browser + version: All
  • Database = mySQL (Don’t hate me)

Expected behavior:

  • Emails or indeed relies on message are displayed in full rather than the error and RAW email attached

Actual behavior:

  • Some replies or indeed new tickets show the message
    This message cannot be displayed due to HTML processing issues

Steps to reproduce the behavior:

  • Not 100% sure, but usually message with excel table formatting or large email replies fail.

Hello all,

I am looking for some input because I cannot seem to resolve this myself.
So, I get this message quite frequently, (picture below) at first I thought it was a performance issue, so I reviewed all my settings and tweaked where needed.
Whenever I get certain types of messages with excel tables in the body the system cannot process them, it does not seem to be related to the size of the message, .ie MB size more over the complexity of the message body itself, also noted the message has 400k characters in the message.

When I try to manually force the process of these messages I would get the below error.

Ok, so the data too long, a common error, so I changed the columns of value_to and value_from to datatype LONGTEXT, that should be even right!( maximum length of 4,294,967,295 or 4GB).
Now the error has moved to this:

E, [2022-11-15T12:40:19.824358 #8906-7260] ERROR – : Could not process string via HtmlSanitizer.cleanup in 20 seconds. Current state:

Can the Sanitizer time-out be increased? Will that solve my issue! I would imagine it is set for a reason, the same way I set transactions in SAP not to exceed a certain runtime, i.e. to protect the system, but in SAP for instance I would run these long-running tasks as a batch or do it at an off-peak time, temporarily increasing the timeout parameter, usually on the weekend.

I did find this topic but it did not help Failing HTML-Processing denies user to access the mail · Issue #2706 · zammad/zammad · GitHub

I am able to recreate the issue in another test system using the RAW email from the original message.
Currently, I have 37 of these messages and the users are getting a bit annoyed as it’s disruptive to their work.

Any input would be really appreciated.

Thanks
Robert

cant help, but i essentially asked the exact same thing yesterday.

linking that ticket for reference.

https://community.zammad.org/t/filtering-of-html/5933/5

Im hoping to wind it out to say 60 seconds or so.

I dont think there will be any negative repercussions from it, other than an email taking longer to get processed and show up in the system. which is not a big deal for us.

Hi,

That is super helpful information and at least nice to know that I am not alone.
I feel an offline VMware snapshot coming up! hahaha.

Maybe at least if I change the parameter “temporarily” it would let me clear the backlog and buy me some time while something official comes along.

Thanks for your input.

Robert

How did you get on?

No response from the team as of yet. But i am unable to test it currently due to workload, so i havent had a chance to build up a virtualised instance of ours to test. We run zammad on a bare metal host and not virtualised currently.

Hi Jason,

I only had time to double the value, “temporarily”, it indeed allowed the system more time to process the messages. I am still left with 20 messages so I will need to increase the parameter again if only to get these messages updated. Once that happens I will revert to default until I have more information.

Just FYI, I did the change and the processing of the message when no one was on the system, your tip was invaluable to me as I had no answers for the users and this workaround at least buys me more time, so thank you again.

Cheers
Robert

I just updated ours to 60 and then rebooted the zammad service.

Is that all that i should need to do? I know nothing about ruby so im not sure if this is the correct approach.

I also ran the command to re-index the emails that failed HTML processing and they have all come in good. so hopefully if all thats needed is to change that value and reboot the service, then we will be onto a winner

How has it been working for you?