Templates don't load owner

Infos:

  • Used Zammad version: 5.0.1-1633784092.372bbb07.stretch
  • Used Zammad installation type: package
  • Operating system: debian stretch
  • Browser + version: Firefox 92.0.1

Expected behavior:

  • if a ticket-template is apllied, the saved owner should be loaded

Actual behavior:

  • the owner stays empty when a ticket-template is applied

Steps to reproduce the behavior:

  • create a new ticket
  • select a template (which was saved and worked with zammad 4.1)
  • click apply

The feature seems to be broken with the update to zammad 5.0. I tried to save a new template and load it, but the owner field is still missing.

Does the agent you’re trying to load in as owner have full permission on the group of question?

Yes.
I tried it myself as admin and I have full permissions for all groups.

I could reproduce the described behavior on the exact version you’ve provided.
I then double tabbed and upgraded to 5.0.2-1635960608.907062b7.buster which, at least on my machine™ does fix the issue.

We’ve been working hard and steady on fine tuning some things.
I’m sure this is indirectly caused by the way Core Workflow functions.

Could you try upgrading as well?

Yes, the update to 5.0.2-1635960608.907062b7 solves the issue!
FYI: The last version I had installed was 5.0.2-1635862975.49759f0b, which still caused the problem.

Thank you very much for your effort!

Unfortunately, the issue seems to be back in 5.0.2-1637239384.29d99f1d