Telegram not responding

Infos:

  • Used Zammad version: 3.1
  • Used Zammad installation source: package
  • Operating system: CentOS 7.6
  • Browser + version:

Telegram channels stop responding.
When sending a message in bot it does not reach to Zammad.
I think the problem is since we upgraded to 3.0 to 3.1.

on the /var/log/zammad/production.log I don’t see any telegram traffic.

Thanks.

Did your upgrade run until the end and thus without errors?
Sounds like broken migrations.

Beside upgrading Zammad, did anything else change on the host?

Could you try reconfiguring Telegram and check again.
If the problem persists, try to reply to existing telegram messages.

If this also fails, the issue must lay way deeper.
On my 3.1 Telegram does work.

Hi @MrGeneration,

I don’t think it’s broken migrations, Because I update via yum update.

Please note that “just” because you’re using a package manager to update Zammad, that doesn’t mean that the update went through without any errors.
We strongly recommend to check the output after updating Zammad.

Sorry, but with the current set of information it’s impossible to help you.

What more information is required?

Running transaction
Updating : zammad-3.1.0-1564403976.b2f434c5.centos7.x86_64 1/1

(Re)creating init scripts

Nothing to do.
Nothing to do.
Nothing to do.

Enabling Zammad on boot

Stopping Zammad

database.yml found. Updating db…

Updating translations…

Configuring Elasticsearch…

-> removing [ingest-attachment]…
-> Downloading ingest-attachment from elastic
[=================================================] 100%
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
@ WARNING: plugin requires additional permissions @
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@

  • java.lang.RuntimePermission accessClassInPackage.sun.java2d.cmm.kcms
  • java.lang.RuntimePermission accessDeclaredMembers
  • java.lang.RuntimePermission getClassLoader
  • java.lang.reflect.ReflectPermission suppressAccessChecks
  • java.security.SecurityPermission createAccessControlContext
  • java.security.SecurityPermission insertProvider
  • java.security.SecurityPermission putProviderProperty.BC
    See http://docs.oracle.com/javase/8/docs/technotes/guides/security/permissions.html
    for descriptions of what these permissions allow and the associated risks.
    -> Installed ingest-attachment

Starting Zammad

Creating webserver bootstart

Restarting webserver nginx

####################################################################################

Add your fully qualified domain name or public IP to servername directive of
nginx, if this installation is done on a remote server. You have to change:
/etc/nginx/conf.d/zammad.conf and restart nginx process.
Otherwise just open http://localhost/ in your browser to start using Zammad.

Remember to enable selinux and firewall rules!

Use the following commands:
setsebool httpd_can_network_connect on -P
firewall-cmd --zone=public --add-service=http --permanent
firewall-cmd --zone=public --add-service=https --permanent
firewall-cmd --reload

####################################################################################

Cleanup : zammad-3.1.0-1562942376.fb3e2d49.centos7.x86_64 1/1
Verifying : zammad-3.1.0-1564403976.b2f434c5.centos7.x86_64 1/1

Updated :
zammad.x86_64 0:3.1.0-1564403976.b2f434c5.centos7

Complete!

I have the same issue,
Zammad is receiving messages from Telegram but did not send.

That’s a different issue from the one in this thread.
It would be great if you could open a new thread with this issue, this will help all of us to keep better track of things. :slight_smile:

@YosefAdPro could you please tell me your region?
Is your server located in a region where Telegram currently is blocked…?

Did you try to remove the current telegram settings and set them new?
Is the API-Key correct?

France.

yes, I opened a new bot.
After I insert the API Key into the zammad it recognizes the bot name …

That’s odd, I can’t reproduce this issue.
Could you please verify if this also affects hosted instances for you? (in my case it doesn’t):
https://zammad.com/getting-started

Also ensure that your server can be reached by the telegram subnets 149.154.160.0/20 and 91.108.4.0/22.
While the above should be no problem, also ensure that you’re using Ports 443, 80, 88 or 8443 for Zammad, as other wise the Telegram webhooks will not work.

You can find more information on the Telegram webhooks here:

Hi,

After I checked the bot status:
https://api.telegram.org/botBOT-TOKEN/getWebhookInfo
I saw that there was a problem with the SSL:

last_error_message":“SSL error {error:1416F086:SSL routines:tls_process_server_certificate:certificate verify failed}”

The problem was in the ca-bundle.

I fixed it and now the telegram works great!
Thanks for your help!

Great!
I’m glad you could fix this issue! :slight_smile:

Thank you also, for the hint of the error that lead you to this!
This will surely help others.