SSL Issue when opening one ticket

Had an issue with my SSL certificate. A client emailed in, however when I open that one ticket… the SSL disappears and I get “The connection to this website isn’t fully secure”. The email that was sent in consisted of only text and their signature, which does have images in, however other tickets with images in work just fine…
It’s not a huge issue, but it would be nice to get to the bottom of it… Any ideas?

I had an agent report the same thing. I didn’t look into it at the time, I assumed like I guess you are it was something in the email linking to a resource over http. If you can reproduce it check the browsers developer tools/console to see if it sheds any light.

It’s the images causing the issue. Do you know if there’s there any way to force SSL on all objects?

not really, but sort of.

The web server the image is hosted on might not have https set up, but if it does there’s a web browser addon called https everyhwere by EFF that might help, but it might not either.

The other option is for a new feature in zammad to rewrite links in emails to go via a proxy in zammad, so if the link in the email is zammad would rewrite it to https://yourzammad.url/proxy? and the image would load via the zammad server over https.

1 Like

I’ll have a look. The server has LetsEncrypt installed on and is set to force the browser to redirect to HTTPS, but not objects. I’ll see if there’s a way in that config to also do it for objects.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.