[solved] Signature images don't work


  • Used Zammad version: V2.9.x
  • Used Zammad installation source: DEB Package
  • Operating system: Ubuntu Server 18.04.2 LTS
  • Browser + version: Firefox 66.0.2 and Chrome 73.0.3683.103 for Windows

Expected behavior:

  • Inserting image via Copy > Paste in to one of our signatures and it should work.

Actual behavior:

When the image is pasted it shows up correctly, but when you press submit and re-open the signature the image is gone.

I have tested the following:

  • Image hosted on another domain
  • Image hosted on zammad using the “branding” option
  • Using the including image in “/opt/zammad/public/assets/images/avatar-bg.png” and using that.
  • Converting from PNG to JPG

Steps to reproduce the behavior:

  • Go to Email > Signatures and opening the default signature. Copy and pasting an image into the signature, save it, after that re-open it and the image is gone.
1 Like

You want to paste the image as inline, that will work.

No linking or such, inserting like you would do with an article.

1 Like

Thank you for the quick reply, that indeed solved my issue!
I tried copying it straight from Windows Explorer which didn’t work also copying and pasting it from another website didn’t work.
When I open the image with Windows Photo Viewer and select copy I can paste it in the signature and it stays there so that solves the issue!

May be helpful for anyone else with the issue.


This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.