[SOLVED]Problem with restore script

Infos:

Important:
If you are a Zammad Support or hosted customer and experience a technical issue, please refer to: support@zammad.com using your zammad-hostname / or company contract.

  • Used Zammad version: 2.7
  • Used Zammad installation source: package
  • Operating system: Ubuntu 16.04
  • Browser + version: Firefox 65.02

Expected behavior:

Restore script should restore Zammad DB and Files in new VM.

Actual behavior:

Restore script throws no permission errors in new VM.

Steps to reproduce the behavior:

When starting the script to restore our configuration from our running system to a new VM, we get errors that we don’t have permissions.

Sadly the documentation is not very clear what the actual prerequisites are.
Do I have to install the same version of zammad?
Do I have to give some special permissions in the new VM?

Please can someone tell me the correct procedere for the restore.

Could you please share the output of the script?
Otherwise helping you is a bit hard - normally following the guideline in our documentation should be enough.

For a successfull restoration your Zammad-Version on the destination system has to be the exact same or newer than the source. No special permissions needed (as far as I’m aware)

Sorry for the delay. The first picture is where I started the script, all is well.
grafik

I then give the administrators password, which also says in the script that it was completed.
grafik

After that I only get Permission denied over everything. It runs through and then says restore completed.
grafik

Thanks for your help.

Forget to mention:

I’m coming from the Ubuntu 16.04 LTS, Zammad Version 2.7 to Ubuntu 18.04, Zammad Version 2.9.

I see that you are doing this as an ‘administrator’ user which propably have no permissions to /opt/zammad.
Script is asking you for a root password because it needs it for restoring/dumping postgresql database and it’s not using su command to untar and overwrite files.

If in your system there is a ‘zammad’ user (and I suppose there is) you should as root do this:

su - zammad
/opt/zammad/contrib/backup/zammad_restore.sh

Just in case - make a backup “from hand” before using the zammad_backup.sh.
I am pretty sure it will solve the issue.

2 Likes

Thank you for your reply.
Your tip was spot on. I had to set the root user and then it worked.

I’m glad it worked for you. Please add [SOLVED] at the beginning of topic.

1 Like

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.