[SOLVED] Problem accessing Zammad under Debian 10.2

Infos:

  • Used Zammad version: Version: 3.2.0-1576685654.40972b3f.buster
  • Used Zammad installation source: https://dl.packager.io/srv/deb/zammad/zammad/stable/debian 10/main amd64 Packages
  • Operating system: Linux debian-10 4.19.0-6-amd64 #1 SMP Debian 4.19.67-2+deb10u2 (2019-11-11) x86_64 GNU/Linux
  • Browser + version: firefox-esr, 68.3.0esr-1~deb10u1

Expected behavior:

firefox-esr localhost

should show “Welcome to Zammad!”-Screen

Actual behavior:

firefox-esr localhost

shows “Welcome to nginx!”-Screen

Steps to reproduce the behavior:

Clean install of Debian 10.2 with:

  • MATE-Desktop-Environment
  • openjdk-11-jre
  • elasticsearch
  • elasticsearch-plugin ingest-attachment
  • zammad

Supplementary information

Checking sudo systemctl status zammad says that zammad.service ist active and running. Also I did not change anything in the /etc/nginx/sites-enabled/zammad.conf yet. What am I doing wrong?

Please provide the configuration of your nginx vHost that’s responsible for your Zammad-Instance.

/etc/nginx/nginx.conf: https://paste2.org/AjNGVKb4
/etc/nginx/sites-available/zammad.conf: https://paste2.org/1wwpY6Aw

If you need further files, please let me know which ones: https://paste2.org/v2E4HJY6

Did you reload / restart your nginx?
Seems like everything is good to go from what I can tell. :slight_smile:

I even restartet the entire server, but the problem remains. Also sudo nginx -s reload && firefox-esr localhost keeps showing the “Welcome to nginx!”-screen. :worried:

Could you take a look if /etc/nginx/sites-available/default is the issue here?
I guess it’s reacting to localhost before the zammad.conf can.

:heart: Thanks for the hint - that fixed my problem. Solution:
sudo rm /etc/nginx/sites-enabled/default
sudo nginx -s reload && firefox-esr localhost


I first tried
sudo mv /etc/nginx/sites-available/default /etc/nginx/sites-available/default.bak,
but that led to the following error message:
nginx: [emerg] open() "/etc/nginx/sites-enabled/default" failed (2: No such file or directory) in /etc/nginx/nginx.conf:62


Where would be the right place to document this workaround/ bug to prevent others from running into similar problems?

That’s because you removed the source of the symlink from sites-enabled folder.
If you remove it from the sites-enabled folder, you’ll be fine

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.