[solved] General update question


#43

But I found another issue on the new server.

{“error”:“Unable to process GET request to elasticsearch URL ‘http://zammad-elasticsearch:9200/zammad_production/Ticket/_search’. Check the response and payload for detailed information: \n\nResponse:\n#\u003cUserAgent::Result:0x00005624b39d9008 @success=false, @body=nil, @data=nil, @code=0, @content_type=nil, @error=”#\u003cSocketError: Failed to open TCP connection to zammad-elasticsearch:9200 (getaddrinfo: Name or service not known)\u003e"\u003e\n\nPayload:\n{:query=\u003e{:bool=\u003e{:must=\u003e[{:range=\u003e{“created_at”=\u003e{:from=\u003e"2019-01-01", :to=\u003e"2019-12-31"}}}], :must_not=\u003e[{:term=\u003e{“state”=\u003e"merged"}}]}}, :size=\u003e0, :aggs=\u003e{:time_buckets=\u003e{:date_histogram=\u003e{:field=\u003e"created_at", :interval=\u003e"month"}}}}\n\nPayload size: 0M"}

So if I understand this correctly, the server cannot reach the following address.
Any idea ?


#44

Sounds like that the container you’re looking at (scheduler? railsserver?) can’t resolve zammad-elasticsearch, which should point to the zammaddockercompose_zammad-elasticsearch_1 container. Is the elasticsearch container running? Check docker ps.


#45

Oh I forgot to tell, that this issue only appears on the new server installed on debian via deb.


#46

I don’t understand. You should be using either zammad-docker-compose:

https://docs.zammad.org/en/latest/install-docker-compose.html

or install via DEB:

https://docs.zammad.org/en/latest/install-debian.html
https://docs.zammad.org/en/latest/install-ubuntu.html

But not both at the same time.


#47

So the current status is as follows.
I was able to restore the backup of Docker-Compose to a new server (installed on Debian via Deb)
So this issue is fixed. (The old Docker-Compose Server is offline)
But the new server has an issue I don’t understand.


#48

Ah, OK. Zammad stores the address of the ElasticSearch server in its settings, and therefore still has the now invalid address http://zammad-elasticsearch:9200 stored in your database. You can check it in the Rails console:

irb(main):001:0> Setting.get('es_url')
=> "http://zammad-elasticsearch:9200"

The correct URL for the DEB installation is probably http://localhost:9200, so change it with the following command in the Rails console:

Setting.set('es_url', 'http://localhost:9200')

#49

The following page will help you:

https://docs.zammad.org/en/latest/install-elasticsearch.html

Ensure to run settings commands after import.
You might also want to create a new search index, as yours is currently broken / incomplete.
This way you’ll ensure you’re not missing information in your idnex


#50

Thanks for the fast repsonse guys !
After executing the 2 following commands, everything was fine again.

zammad run rails r “Setting.set(‘es_url’, ‘http://localhost:9200’)”
zammad run rake searchindex:rebuild