Setting up Zammad on Mac

Hi!
I want to install zammad from source and have been following the steps from https://docs.zammad.org/en/latest/install/source.html#on-mac-os-10-8

I am trying to install it on a Mac with

  • Catalina 10.15.3
  • Ruby version 2.5.5
  • Bundler version 1.17.3

#Error
The error that I get is the following:
image

#Attempt
I tried to solve it by changing the libv8 version on the gemfile to ‘7.3.492.27.1’ however that was like a snowball because then ruby_racer failed, I changed the version and then mysql2 failed…

Has anyone experienced this? And if yes, how were you able to install it? Or did you use docker?

Thank you in advance and I hope somebody could give some input. Also, please let me know if I need to provide something else.