Set custom object values in postmaster filters

Infos:

  • Used Zammad version: 5.2.0-9
  • Installation method (source, package, …): docker-compose
  • Operating system: Docker
  • Database + version: Zammad Postgres 5.2.0-9
  • Elasticsearch version: 5.2.0-9
  • Browser + version: Chrome 102.0.5005.115

Expected behavior:

  • Object value is set according to filter action (my understanding is that this was implemented in #394)

Actual behavior:

  • Object value is set to default value

Steps to reproduce the behavior:

The scheduler logs show

I, [2022-06-29T17:34:23.109831 #1-110300]  INFO -- : fetching imap (mail.company.com/my-company@company.com port=993,ssl=true,starttls=false,folder=INBOX,keep_on_server=true,auth_type=LOGIN)
I, [2022-06-29T17:34:23.316989 #1-110300]  INFO -- :  - message 1/1
I, [2022-06-29T17:34:23.374086 #1-110300]  INFO -- : Process email with msgid '<xxxxxxx@company.com>'
I, [2022-06-29T17:34:23.383090 #1-110300]  INFO -- :   matching content 'from' contains some-email@abc.com
I, [2022-06-29T17:34:23.388653 #1-110300]  INFO -- : set_attributes_by_x_headers header x-zammad-ticket-priority_id found. Assign priority_id=3
I, [2022-06-29T17:34:23.388690 #1-110300]  INFO -- : set_attributes_by_x_headers header x-zammad-ticket-customer_id found. Assign customer_id=54
I, [2022-06-29T17:34:23.408136 #1-110300]  INFO -- : set_attributes_by_x_headers header x-zammad-article-preferences found. Assign preferences={"send-auto-response"=>true, "is-auto-response"=>false}
I, [2022-06-29T17:34:23.448708 #1-110300]  INFO -- : Execute trigger (auto reply (on new tickets)/1) for this object (Ticket:1484/Loop:1)

But the ticket is created with autoreply set to yes:
2022-06-29 21_38_07-Zammad Helpdesk - #451483 - Test14

I initially thought this was a bug #4154 because it works exactly as expected with an action that adjusts the priority and my understanding is that it was implemented in #394. But since it was closed, maybe I’m doing something wrong?

I can’t reproduce the described behavior with default value set.
Please ensure that you have no triggers or other filters possibly getting in your way.

Also, please update your instance to the latest available version to ensure this is nothing temporary. Should work fine.