Regex Filtering Broken?


  • Used Zammad version: 3.6
  • Used Zammad installation source: (source, package, …)
  • Operating system: Docker (Alpine Host)
  • Browser + version: Chrome (Most recent version as of 03/01/21)

Expected behavior:

  • Filtering w/ regex should show results in the preview area

Actual behavior:

  • 0 tickets appear in the results area regardless of what I input for regex filtering

Steps to reproduce the behavior:

  • Within any area where filtering can be done by From → Contains, enter a regex type. Nothing appears. Per the instrucitons via the KB article at Filters — Zammad documentation I currently have entered regex:(.|@) to filter by our domain, but nothing appears

Hi Matt,

it seems like your regex does not match anything:

I guess it should read (.| instead.

I would recommend to use to check the syntax.


Sorry, looks like it’s still a no go

I’ve tried it a bunch of different ways testing against the link your provided. Not sure what I’m doing wrong.

Hello again,

try with



Dots are part of regular expressions.
They need to be escaped with \.

We have a sample in the documentation that should cover your case:

1 Like

Hi, thank you for the suggestions.

I realized now looking back at the doc, the regex filtering seems to be something that only works on the email filter, not elsewhere. I haven’t tried it yet, but I’m guessing this is my issue

1 Like

the regex filtering seems to be something that only works on the email filter, not elsewhere

Yes this is true sadly. I would love to have regex filtering in triggers and automations but it’s not available there.

1 Like

Well good news is it looks like it’s working. I’ve implemented the filtering for our backup reports and as of this morning it looks like the filtering + actions are triggering correctly

1 Like

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.