Placetel Notification result in http 500

Infos:

  • Used Zammad version: 3.4.x
  • Used Zammad installation source: (source, package, …) package
  • Operating system: ubuntu 18.04
  • Browser + version:

Expected behavior:

when someone calls us Zammad make a log entry
*

Actual behavior:

get an error in the log in Settings->Integrations->Placetel
*

Steps to reproduce the behavior:

I found this log

|Method|POST|
| --- | --- |
|Status|500|
|Request|HTTP_VERSION: HTTP/1.0

HTTP_HOST: [beratung.example.com](http://beratung.example.com)

HTTP_X_FORWARDED_FOR: [35.246.161.xxx](http://35.246.161.xxx)

HTTP_X_FORWARDED_PROTO: http

HTTP_CONNECTION: close

HTTP_X_PLACETEL_SIGNATURE:

HTTP_CLIENT_IP: [35.246.161.xxx](http://35.246.161.xx)

call_id=9e9b31882d1a1a4...&direction=in&duration=0&event=HungUp&from=012345&to=012345&type=missed|
|Response|X-Frame-Options: SAMEORIGIN

X-XSS-Protection: 1; mode=block

X-Content-Type-Options: nosniff

X-Download-Options: noopen

X-Permitted-Cross-Domain-Policies: none

Referrer-Policy: strict-origin-when-cross-origin

Content-Type: text/html; charset=utf-8

<!DOCTYPE html>

<html class="dark">

<meta charset="utf-8">

<title>500: Something went wrong</title>

<link rel="stylesheet" href="/assets/error/style.css">

<body >

<h1>500: We're sorry, but something went wrong.</h1>

<div class="error-image" style="background-image: url(/assets/error/error-2.svg)"></div>

<p>We're sorry, but something went wrong.</p>

</body>

</html>|
|Erstellt am|2020-09-22 09:01:14|

what can I ty to fix it?

just to give feedback

we changed Mysql-server (we migrate to a new server)
newer mysql versions have a sql-mode “strict” which don’t allow zero dates

the solution was

sql-mode="ERROR_FOR_DIVISION_BY_ZERO,NO_ZERO_IN_DATE,NO_AUTO_CREATE_USER"

in my.cnf

1 Like