Password Digit Required Default 'YES" How to Change to "NO"

  • Used Zammad version: 3.4.x
  • Used Zammad installation source: (source, package, …) debian 10 (buster) .deb
  • Operating system: debian buster (10)
  • Browser + version: Google Chrome + Version 85.0.4183.102 (Official Build) (64-bit)

Expected behavior:

  • Went through the docs and rails commands but could not find how to turn Password Digit Required Default from “yes” to “no”.

Actual behavior:

  • Reason? I am using an AOL email ID. Starting October 2020 AOL/Yahoo are changing their login requirements. One option they provide is a special AOL generated password string to use in zammad (aka. 'Other" 3rd Party App). Their generate password, while complex, does NOT contain a digit. So, rather than chasing after AOL/Yahoo, I thought I would check with the community if anyone knows how to change this flag from ‘yes’ to ‘no’?

Steps to reproduce the behavior:

  • Enter AOL’s generated App Password (which contains no digits). I get a response back from Zammad: “Invalid password, it must contain at least 1 digit”.

Sorry but I can’t reproduce this with a current Zammad 3.4 stable.
To me it feels like you’re mixing up email channels with user accounts where this restriction would be available if required.

To verify I just set a password without any digits on my own mail server and added (and also updated to test both cases) a email channel.

If your issue still persists, please also provide a screenshot showing the exact error message.