Office 365 SMTP Failing


I’ve looked through the other posts on this and I saw that it now states Zammad now works with Office 365 out of the box. I’ve gone through those posts and nothing in there solves the issue. I’m pretty technical on the network side of things and have some understanding of development (but nothing on the Ruby side).

Things I’ve tried:

  • Letting it try to connect automatically (out of the box)
  • Manually putting in the settings
  • Connecting to Office 365 via an SMTP relay (yes I have set this up correctly in Office admin)

I know user name / password are correct and I’m pretty sure it should just work with one of the above with no fancy configurations.

Below are the errors I get. (I’ve tried port 25 too). I know Office 365 no longer supports older versions of TLS, so I’m starting to think it’s that. Any other ideas?

“Authentication unsuccessful” is a very clear error message that states your login data being wrong…!

I get that, but I can log in to the Outlook portal just fine with that mailbox which is why I don’t think it’s a user name / password issue.

This is not a shared mailbox and IMAP + SMTP is enabled?

OK solved it - I’ll concede it was something to do with Office 365…

Increased the licence from Business Essentials to Business Premium, convert the mailbox to a shared mailbox and then back to a regular mailbox and it let me connect.

I’ve since downgraded the licence back to Business Essentials and it’s still working.

1 Like

What the actual f*ck?

Well, thanks for letting us know it works now, glad it does. :slight_smile:

Oh I have no idea!!! Maybe it helps someone else who’s having a stupid issue like this!

1 Like

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.