Oauth broken since 21.08.23


  • Used Zammad version: 5.0.x
  • Used Zammad installation type: docker
  • WIN 11, Chrome 116.0.5845.111

Expected behavior:

M365 Channel works as before and creates tickets

Actual behavior:

  • tickets are not created and the mails are not deleted from the mailbox

everything worked until last monday. We changed nothing. Each setting resembles the documentation. Reauthenticate + deleting channel + add as new m365 account doesnt help.

The log says only this about oauth:

Before anything else, please upgrade this very old and security prone version of Zammad. The current stable version is Zammad 6.0.

Your description is not exactly clear. Is it successfully fetching emails or is it not? Any error messages?

We do not have any errors. We will update and then we will see, if it fixes the problem already.
Thank you!

We updated to version 6.0. Unfortunately zammad is still not creating tickets.

I can answer existing emails.

You don’t have a second Zammad installation laying around to test stuff do you?
If this is an exact copy, most likely your mail is landing there.
At least that would explain your explanation, you wouldn’t be the first to have this happen.-