New User Notifications

Infos:

  • Used Zammad version: 5.0.x
  • Used Zammad installation type: (source, package, docker-compose, …) package self hosted
  • Operating system:
  • Browser + version: Firefox 98

Expected behavior:

  • Welcome notification

Actual behavior:

Welcome notification not being sent

Steps to reproduce the behavior:

  • create new user

I created a new AGENT user (no password) and the user did not receive a notification. As far as I know Mail SMTP through my mail server is functioning as I receive mail from Zammad.

Did I turn something off?

After a bunch of searching “new agent email”, “new user email” … I finally ran across a customer invite post where someone mentioned the “First Steps Tab”. I think that will send an email to any new agents I create.

OK the mail is being sent BUT the link does not work.

The link looks something like this

http://{my domain}.com/#password_reset_verify/dkuhywig2f8to3978gfcue9783tby98 b

(I made up the string after password_reset_verify/) So I guess I have something configured wrong. I remember somewhere it asked for the full name and since I didn’t have this server in DNS I didn’t give a FQDN

I’ll try to sort that out now where was that setting …

Added the DNS entry Then on Zammad went to settings > System > BASE and entered the server’s fully qualified name. That did the trick.

I will no doubt forget about this First Steps tab. If only there was a way to notify newly created agents that are done on the user’s form/screen …