New Priority's Don't Appear from the Agent Web Form Creation

EDIT 8-19-2021

It looks like signing in with a different agent account fixed the problem. I was using the local admin user that was created during the install, I logged out and into my SAML account and I had the right priority’s available to choose from. I then logged out of my SAML account and back in as the local user and the priorities where there. It must be a weird cache thing!

  • Used Zammad version: 4.1 (Installed from Zammad Documentation)
  • Used Zammad installation type: Package Installation
  • Operating system: Ubuntu Server 20.04
  • Browser + version: MS Edge (Chrome Build) V92.0.902.73 (Official build) (64-bit)

Expected behavior:

  • When creating a new Priority Level Through the API, it should appear everywhere as a selection. Also when deleting Priority level’s they should delete everywhere

New Priorities I created

I deleted all the old priorities such as 1 - High, 2- Medium etc…

Actual behavior:

  • When Creating a Priority Level through the API, it creates and is selectable everywhere except the agent ticket form area.

Old Priorities

When Creating a ticket through the internal agent ticket creation form, the following error shows up since none of the new priority levels appear for a choice

Steps to reproduce the behavior:

  • Have used the API to create new Priority Levels and the same issue happens again.

've tried changing the default priority level through the Rails Console and that works, when a ticket is created the default priority level 2 is assigned. However, this only works when submitting a ticket as “end user”, when submitting a ticket as a agent, i get the error about the priority_id from above

Sounds like a caching issue to be honest.
Sometimes a friendly but demanding CTRL+SHIFT+R does the trick.

Possibly the local account would work now too. :slight_smile:

I guess your issue is solved by that?

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.