Migrating issue from host A to B


Hello, I followed the backup script like here to migrate to a new host: https://docs.zammad.org/en/latest/appendix/backup-and-restore.html
Updated old host to 3.4.0 first and tested everything, worked fine, stopped service, created backup and transferred to new host, installed 3.4.0 there and restored the backup.

Expected behavior:

Continue using Zammad on the new host.

Actual behavior:

Error 502 Bad Gateway from nginx until running:
dpkg -r --force-depends zammad
apt install zammad
zammad run rails r “Setting.set(‘es_url’, ‘http://localhost:9200’)”
zammad run rake searchindex:rebuild

After that, I can see my old tickets and new tickets are coming in by mail, but I can’t reply by mail (button is missing). I found no way to set or restore the required rights.

Steps to reproduce the behavior:

Tried multiple times like described above, always the same result with my backups and restorings. Might be hard to reproduce with another environment.

Sounds like your mail account configuration got lost.
This usually doesn’t happen during a mere migration which is why this might have been on the original system already.

Check your group configuration.
Also see:

Thank you, I also suspect issues with the original system. Group and role managements seem somehow damaged, too - I’m missing lots of the documented functionality and changes in groups/roles lead to errors that are not recoverable by UI (fortunately we have backups).
I tend to setting up a clean, new system, but I’d like to import tickets and tags at least via the database. I hope this is possible, any hints or documentation about that would be much appreciated.

Manual import of data (so basically merging two Zammad systems) is absolutely not supported.
While it’s technically possible it requires tons of manual work and reworking of your data.

Zammad uses tons of references which you might have to adjust during adding new data - there’s no howto or best practises to do so.

I’m sorry, it’s out of scope.

Missing functionalities sounds very odd.
You’re migrating from a selfhosted to selfhosted host…?

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.