Mailfilter: "+" within "to" field to autoassign groups

hello.

we try to use e.g. the e-mail address “ticketsomething+mailing AT tugraz.at” and a filter in zammad to automatically assign the tickets to the group “mailing”.

that would be a wonderful possibility :slight_smile:

this works for “normal” customers.

but if the sender is known to zammad in a higher privileged agent group, the customer “ticketsomething+mailing AT tugraz.at” is erroneously assigned to the ticket. the real “from” adress is ignored. and then you can’t reply to the ticket anymore.

the email arrives correctly, but the customer assignment does not seem to support this “+” under some circumstances. is this a bug? theoretically “+” is allowed in emails.

please let me attach the email filter:

Sorry but I don’t understand your aim.
I can’t reproduce “the wrong customer being recognized”.

In fact your filter doesn’t say anything about customer users.

If you wanted to ask how you can ensure Zammad to re-route a ticket if a mail alias contains +something no matter what the domain part and part before +something is, the answer would be: a regular expression.

Please also note: Postmaster-Filters are case sensitive - the + character is part of regular expression commands and thus may need to be escaped. (see https://en.wikipedia.org/wiki/Regular_expression#Basic_concepts for more)


But maybe I’m just not able to understand your goal. Sorry.

This is caused by the setting under Channels -> E-Mail -> Settings where you can choose to take the first recipient address as the ticket customer if the sender is an agent.
You could try turning this off and also changing your Postmaster Filter to regex:(\+mailing)

Thank you very much to both of you, I will try to clarify the issue, test and report back.