Language settings for initial administrator account page

Hi Zammad team,

Thank you all to develop such amazing open source application!

I met a strange problem when first time setting up Zammad. I setup Zammad on a minimal CentOS 7 box that default language of the OS is en_US.UTF8, and access web page to initial admin account of Zammad from my Linux box which is a Ubuntu 18.04 with en_US.UTF8 language setting and Chrome browser with also English language by default.

Once I first time access the web page, it gives me Japanese language as default.

BTW, I then initialized Zammad and setup English language on both profile and brand settings (Thanks to Google Translate!). That gives me English interface until I close the browser tab. But it still gives me Japanese interface when I open a new browser tab and access Zammad helpdesk page again.

I also notice that there are optional settings about Geo-IP related services, and I close them. But nothing helps.

(Sure I am in east Asia and system time is GMT+8).

Most of modern services using Browser or OS language to initial their first page. Why not Zammad do the same?



Sorry, more details:

  1. I followed the official document to install it (yum method).
    rpm -qa | grep zammad zammad-2.5.0-1529074564.4c6b1067.centos7.x86_64

  2. ruby version: I update and use ruby 2.4.3 as environment to install and run zammad. But it switch back to 2.0.0p648 after reboot. I am not sure the exact version that Zammad uses.