Knowledgebase not managable after update

Infos:

  • Used Zammad version: 3.1
  • Used Zammad installation source: DEB installer
  • Operating system: Debian 9
  • Browser + version: Latest Firefox + Chrome

Expected behavior:

  • Settings tab for the knowledgebase shows as active and I can manage the parameters

Actual behavior:

  • When I try to manage the knowledgebase I see it as deactivated.
  • If you click activate it shows in the log but the button switches back to offline.

Steps to reproduce the behavior:

  • Go to knowledgebase.
  • Click on activation button.
  • Like this:
    knwoledgbase

Precceding Steps

  • I patched Zammad with apt-get upgrade

Log output for a try to manage the Knowledgebase

I, [2019-09-05T08:54:22.679570 #24877-47258800131200] INFO – : Started GET “/api/v1/knowledge_bases/manage/init?=1567525680181" for IP redacted at 2019-09-05 08:54:22 +0200
I, [2019-09-05T08:54:22.688424 #24877-47258800131200] INFO – : Processing by KnowledgeBase::ManageController#init as JSON
I, [2019-09-05T08:54:22.688535 #24877-47258800131200] INFO – : Parameters:{"
”=>“1567525680181”}
I, [2019-09-05T08:54:22.711776 #24877-47258800131200] INFO – : Completed 200 OK in 23ms (Views: 0.7ms | ActiveRecord: 4.7ms)
I, [2019-09-05T08:54:26.779905 #24877-47258855664740] INFO – : Enqueued UserDeviceLogJob (Job ID: 20d45fb2-a44d-4647-bf10-0e549c7bacd1) to DelayedJob(default) with arguments: "Mozilla/5.0 (Windows NT 10.0; Wi$
I, [2019-09-05T08:54:26.788200 #24877-47258855664740] INFO – : Enqueued ChecksKbClientNotificationJob (Job ID: 2f24ff13-f5f3-4dcf-ae54-60b579d3ba25) to DelayedJob(default) with arguments: “KnowledgeBase”, 1, $
I, [2019-09-05T08:54:26.791563 #24877-47258855664740] INFO – : Setting.set(‘kb_active’, true)
I, [2019-09-05T08:54:26.795547 #24877-47258855664740] INFO – : Setting.set(‘kb_active_publicly’, true)
I, [2019-09-05T08:54:26.820293 #24877-47258855664740] INFO – : Completed 200 OK in 100ms (Views: 0.3ms | ActiveRecord: 72.9ms)
I, [2019-09-05T08:54:28.731843 #24872-70160509340000] INFO – : execute Job.run (try_count 0)…

Please try a clean reload of the WebApp (CTRL+SHIFT+R) to ensure you’re not being striked by caching.
Also, please ensure that all migrations (during your upgrade) where fine.

Maybe also a friendly zammad run rails r 'Cache.clear' helps you here.

1 Like