Issues after upgrading to Zammad 4.0


  • Used Zammad version: 4.0.0-1617678167.2e3acf80.stretch
  • Used Zammad installation source: package
  • Operating system: Debian Stretch
  • Browser + version: Brave Version 1.22.71 Chromium: 89.0.4389.114


  • Cannot assign tags for tickets ( after updating ticket, tags are not saved)
  • Cannot merge tickets ( “No route matches [GET] /api/v1/ticket_merge…” )
  • There is some issue w/ OpenSSL apparently
# su zammad
Using /opt/zammad/.rvm/gems/ruby-2.5.5
Error loading RubyGems plugin "/opt/zammad/.rvm/gems/ruby-2.5.5@global/gems/executable-hooks-1.6.0/lib/rubygems_plugin.rb": /usr/lib/x86_64-linux-gnu/ version `OPENSSL_1_1_1' not found (required by /opt/zammad/.rvm/rubies/ruby-2.5.5/lib/ruby/2.5.0/x86_64-linux/ - /opt/zammad/.rvm/rubies/ruby-2.5.5/lib/ruby/2.5.0/x86_64-linux/ (LoadError)
Error loading RubyGems plugin "/opt/zammad/.rvm/gems/ruby-2.5.5@global/gems/gem-wrappers-1.3.2/lib/rubygems_plugin.rb": /usr/lib/x86_64-linux-gnu/ version `OPENSSL_1_1_1' not found (required by /opt/zammad/.rvm/rubies/ruby-2.5.5/lib/ruby/2.5.0/x86_64-linux/ - /opt/zammad/.rvm/rubies/ruby-2.5.5/lib/ruby/2.5.0/x86_64-linux/ (LoadError)

I tried so far:

  • upgraded ruby from 2.5.5 to 2.6.6
  • cleared Zammad cache
  • cleared entire browser cache and tried other browsers
  • re-installed zammad from latest apt package

I am still not able to assing any tags or merge tickets (ActionController::RoutingError)

Same problem with adding links to tickets:

No route matches [GET] /api/v1/links/add (ActionController::Routi

OK I searched more here and it seems now it’s working… :smiley:

zammad run rake assets:precompile

1 Like

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.