Internal Answers in Knowledgebase are visible to Costumer


  • Used Zammad version: 3.1x
  • Used Zammad installation source: (source, package, …) Centos RPM
  • Operating system: Centos 7
  • Browser + version: All

Expected behavior:

  • Internally marked replies should only be visible to agents

Actual behavior:

  • Internally marked answers are visible to customers. Only if we mark the article as a draft, it is hidden from the customer

Steps to reproduce the behavior:

Do you have tips for troubleshooting? Best regards, Peter

Can you please share the visibility setting for the affected answer and maybe also check if the customer has any special role-settings or roles itself?

Hi MrGeneration, thanks for Reply. I’ll send you three screenshots. The customer is in the role of customer. The knowledgebase rights are on Reader.


Many thanks for your help

Please remove the reader right from your customer role.
This should address your issue.

1 Like

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.