Installation on CentOS 8

  • Used Zammad version: 3.6.0
  • Used Zammad installation source: RPM
  • Operating system: CentOS 8
  • Browser + version: Firefox

Hello!

I’m new to Zammand and try to install the system.

I’’ imstalling Elasticsearch according to the documentaion.


and

When installing Elasticsearch I get this error:
sudo /usr/share/elasticsearch/bin/elasticsearch-plugin install ingest-attachment --verbose
-> Installing ingest-attachment
Checking if url exists: https://artifacts.elastic.co/downloads/elasticsearch-plugins/ingest-attachment/ingest-attachment-linux-x86_64-7.10.0.zip
-> Failed installing ingest-attachment
-> Rolling back ingest-attachment
-> Rolled back ingest-attachment
Exception in thread “main” java.net.UnknownHostException: artifacts.elastic.co

After some reseach, I managed to install th plugin manually:
sudo /usr/share/elasticsearch/bin/elasticsearch-plugin install file:///home/reppler/ingest-attachment-7.10.0.zip -verbose

Why does the automatic installaion get the wrong filename?
Is this a error in my configuration?

Then I installed Postgresql and Zammad.
This workd without problems.

Now I’trying to connect Elasticsearch with Zammad:
zammad run rails r “Setting.set(‘es_url’, ‘http://localhost:9200’)”

I get the following error:
/opt/zammad/vendor/bundle/ruby/2.6.0/gems/bootsnap-1.3.2/lib/bootsnap/load_path_cache/core_ext/kernel_require.rb:21:in `require’: libgcrypt.so.11: cannot open shared object file: No such file or directory - /opt/zammad/vendor/bundle/ruby/2.6.0/gems/nokogiri-1.10.9/lib/nokogiri/nokogiri.so (LoadError)

On my system libgcrypt.so.20 is installed.
How can I solve the problem?

I’m new to Linux and CentOS. So please be patient with me…

Thanks for your help!

Same basic issue here
CentOS 8

Followed the same instructions and have the same basic issue.
localhost (set to localhost or ip in config) goes to nginx demo page.

Appears to be an elastic search problem.

Hi all,

if you are having issues installing Zammad from scratch, I would suggest you use this installer script which will take care of everything for you.

It is usually faster/better than going through long and painful troubleshooting.

For the sake of completeness: this is an unofficial installer. However, it has been proven to work under CentOS 8, Ubuntu 18.x / 20.x and OpenSUSE 42.

HTH.

Best,
Martin

I didn’t see this kind of issue on my run throughs.
Any way, this is more likely an Elasticsearch issue and has nothing to do with Zammad.

So if the issue still persists, they’ll probably able to help you better than we do.
We have no power over they’re files etc. :slight_smile:

Hi!

I finally found the problem:
Installing an plugin for elasicsearch does not support proxy authentication.
To solve the problem, I installed Privoxy and let it do the authenication.

Thanks for your help :slight_smile:

2 Likes

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.