Incorrect JS file in assets directory

Infos:

  • Used Zammad version: 3.6.0-1613047982.332fdca8.focal
  • Used Zammad installation source: Package
  • Operating system: Ubuntu 20.04
  • Browser + version: any

Expected behavior:

  • Loads

Actual behavior:

  • Sticks on loading screen

Problem

Using the dev tools, one of our systems is requesting /assets/application-b38e524c377212c7d1cb2b7df1a7da2ef394ecf99458976ac602ca5f9f3b5db8.js after the latest update last night. The file doesn’t exist.
The other system is fine.

I’ve got around it by linking that file to the correct one (ln -s) application-cb9da2311774c1faafef27c46a502bb6bd417475bddb62434a390d6ea56de882.js

Is that an old file still being called after the update, or has it made it up from somewhere?
I did an apt reinstall and nothing changed.

I’m hoping the next update will fix this, but we’ll have to see when it comes out.

This sometimes happens if something odd happens during building or installing.
To me it happens super rarely (also for our customers) which is why I couldn’t pin down the reason to it.

In general the following steps will help without linking stuff:

systemctl stop zammad
zammad run rake assets:precompile
zammad run rails r "Cache.clear"
systemctl start zammad

Above shouldn’t be required often but helps if something went terribly wrong with asset files.

2 Likes

Oh, that’s fixed it. Link removed and all OK now.

Thanks

1 Like

I had the same issue and your fix worked for me. Perfekt!!! thank you.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.