Ignore Reply-To header when answering


  • Used Zammad version: 4.1.x
  • Used Zammad installation type: package
  • Operating system:
  • Browser + version: Chrome Version 93.0.4577.63

Expected behavior:

  • When an agent replies to an article of a customer and a reply-to header is set, the reply-to header should be completely ignored so the answer goes out to the source e-mail address.

Actual behavior:

  • In Zammad Admin Panel, e-mail channel settings, you can set 3 options for “Sender based on Reply-To header:”:
    unset, Take reply-to header as sender/from of email, Take reply-to header as sender/from of email and use realname of origin from
    If you click on “reply” in a ticket and the reply-to header is set, the answer will be going to address in the reply-to header. There is no option to ignore the header completely in ticket editing or admin panel. Answer allways going out to a reply-to address if set.
    Example situation: A hacker has set the reply-to header to get all answers or a customer has set it accidentally. So we want to have an option to ignore the reply-to header completely. An additional option in the admin panel would be great.

Steps to reproduce the behavior:

  • Simply click on “reply” in a ticket where the reply-to header is set

Zammad always takes the Reply-To-Header into account.
Turning this functionality off is currently not possible (also see the documentation describing the options: Settings — Zammad documentation )

If you believe that’s a thing and relevant function, please create a feature request on this board.

1 Like

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.