How to use group name #{} correctly URL encoded


If you are a Zammad Support or hosted customer and experience a technical issue, please refer to: using your zammad-hostname / or company contract.

  • Used Zammad version: 2.8.x
  • Used Zammad installation source: (source, package, …) package
  • Operating system: Ubuntu 16.04.5
  • Browser + version: Chrome

I want to use the group name (#{}) in an email, that is send to the customer from a trigger. The group name is used in a link. When the group name has spaces in it, the link will be cut off. Is there a way to URL encode Strings in a trigger?

Expected behavior:

Actual behavior:

Steps to reproduce the behavior:

I cannot help you with the improper stripping of a group name, but if this not an issue - export your users into CSV, use awk/sed to remove spaces and change them to for example “_” in group names, reimport and it should temporarily solve your case.

Please do not treat my idea as an final solution. It’s just a shortcut.

What exactly are you trying to do?
You can’t reach groups in Zammad via URL.

I’m writing a survey tool that customers should be sent to when their ticket is closed. Since we support different products in our Zammad, we have created groups that represent the different products.

The mail the customer receives should contain links of this kind:
Are you satisfied with our support? Please click here:
Are you dissatisfied with our support? please click here:

But I can’t produce the link like this, because our group names contain spaces. Otherwise I could just use #{}. I had hoped that I could use some code in the editor for the mail from the trigger that url-encodes me such a variable. But I guess I have to use #{} in the link to get the name of the group from the API. Or is there an easier way to do that?

No easier way in my opinion no.
Another option would be a custom object, but well, not sure if that’s good enough for you.

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.