How to reimport mails?

Infos:

  • Used Zammad version: 5.1.x
  • Used Zammad installation type: package
  • Operating system: CentOS 7
  • Browser + version: all

Expected behavior:

  • I need to reimport mails: I mark the mails as ‘unread’ and move them back to my IMAP inbox. Usually they get imported as new mails.

Actual behavior:

  • the mails getting processed, but not imported. production.log shows:
    I, [2022-06-22T12:37:17.274810 #672-7500] INFO – : Running job thread for ‘Execute planned jobs.’ (Job.run) status is: sleep
    I, [2022-06-22T12:37:24.261078 #672-312040] INFO – : execute Channel.fetch (try_count 0)…
    I, [2022-06-22T12:37:24.263419 #672-312040] INFO – : fetching imap (Working... port=993,ssl=true,starttls=false,folder=INBOX,keep_on_server=false,auth_type=LOGIN)
    I, [2022-06-22T12:37:24.651375 #672-312040] INFO – : - no message
    I, [2022-06-22T12:37:24.662068 #672-312040] INFO – : fetching imap (Working... port=993,ssl=true,starttls=false,folder=INBOX,keep_on_server=false,auth_type=LOGIN)
    I, [2022-06-22T12:37:25.394913 #672-312040] INFO – : - no message
    I, [2022-06-22T12:37:25.413003 #672-312040] INFO – : fetching imap (Working... port=993,ssl=true,starttls=false,folder=INBOX,keep_on_server=false,auth_type=LOGIN)
    I, [2022-06-22T12:37:25.972042 #672-312040] INFO – : - message 1/3
    I, [2022-06-22T12:37:26.092051 #672-312040] INFO – : - ignore message 1/3 - because message has already delete flag
    I, [2022-06-22T12:37:26.092190 #672-312040] INFO – : - message 2/3
    I, [2022-06-22T12:37:26.173516 #672-312040] INFO – : - ignore message 2/3 - because message has already delete flag
    I, [2022-06-22T12:37:26.173657 #672-312040] INFO – : - message 3/3
    I, [2022-06-22T12:37:26.253172 #672-312040] INFO – : - ignore message 3/3 - because message has already delete flag
    I, [2022-06-22T12:37:26.573581 #672-312040] INFO – : ended Channel.fetch took: 2.317895125 seconds.

Steps to reproduce the behavior:

  • mark mail as read and move it to the inbox.

My question:

How can I remove the ‘delete flag’? I thought, it’s enough to mark the mail as unread the reimport it.